Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 18234
Status: rejected
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: dagolden [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: RFE: Use installed Module::Install if newer than bundled version?
Download (untitled) / with headers
text/plain 888b
Would it be possible to have Module::Install favor an installed version of itself if that version is higher than the bundled version in inc? Use case: Module is distributed with old Module::Install that has known bugs. Rather than wait for module to be re-released by author with an updated Module::Install, user instead installes an up to date Module::Install and the bundled version loads the installed version instead of the bundled version, thus allowing the module to be immediately installed. I think this would require a facade Module::Install that sets @INC appropriately based on its version versus an installed version, and then bootstraps something like Module::Install::Heavy. This would add versatility to the Module::Install model, allowing power-users to work around installation bugs that are solely due to outdated Module::Install being bundled with a distributions.
Subject: Re: [rt.cpan.org #18234] RFE: Use installed Module::Install if newer than bundled version?
Date: Sun, 19 Mar 2006 18:16:40 +1100
To: bug-Module-Install [...] rt.cpan.org
From: Adam Kennedy <adam [...] phase-n.com>
I think this may be a duplicate of a bug from last week? In short, the answer is (in point form). 1. Users should never (have to) install Module::Install themselves. 2. Certainly, we should never rely on them doing so. In fact I never ever want to see the words "users should first install the latest Module::Install" in any documentation or email advice, except in special circumstances for specific individuals. 3. This possibility only rests with users than are also authors 4. Authors are expected to have Module::Install installed, and updated to the most recent version. 5. In that case, it's dubious (but an interesting idea though) to allow them to use a newer installed version instead of the bundled one. A change in command names could result in a Module::Install script meaning something different or not working. 6. No Makefile.PL is guaranteed to work with ANY Module::Install version other than the one that it comes bundled with (for now). 7. If this feature is added, it won't be until everything, including the command names and APIs are all frozen solid and we go post-1.0. 8. Even then it's a maybe and probably the subject of a special flag of some sort. 9. Module::Install is useful now, but still not strictly "done" yet, so early adopters will be expected to have to do an incremental release from time to time (every 3-6 months would be useful). 10. These problems all stem from a preference in favour of the user, and may result in some short term annoyances till things stabilise more. 11. Thanks for your patience :) via RT wrote: Show quoted text
> Sat Mar 18 17:16:17 2006: Request 18234 was acted upon. > Transaction: Ticket created by DAGOLDEN > Queue: Module-Install > Subject: RFE: Use installed Module::Install if newer than bundled version? > Owner: Nobody > Requestors: DAGOLDEN@cpan.org > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=18234 > > > > Would it be possible to have Module::Install favor an installed version > of itself if that version is higher than the bundled version in inc?
Confirming this will not be happening, it creates more problems than it solves.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.