Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 18181
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: GAAS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.60
Fixed in: (no value)



Download (untitled) / with headers
text/plain 365b
Module::Install interacts badly with ActivePerl::Config because it overrides @INC with the result that the base pragma can't load on case insensitive file systems. See <http://bugs.activestate.com/show_bug.cgi?id=45338>. The attached patch remove the @INC override which should not be needed since find_extensions returns paths with $path already prefixed.
Subject: module-install-inc.patch
--- lib/Module/Install.pm.orig 2006-03-15 13:16:09.000000000 +0100 +++ lib/Module/Install.pm 2006-03-15 13:16:15.000000000 +0100 @@ -195,7 +195,6 @@ unshift @INC, $self->{prefix}; } - local @INC = ($path, @INC); foreach my $rv ( $self->find_extensions($path) ) { my ($file, $pkg) = @{$rv}; next if $self->{pathnames}{$pkg};
From: tshinnic [...] io.com
Download (untitled) / with headers
text/plain 389b
It has been verified (by myself and another) that Module-Install-0.61 does work on ActivePerl on Windows. Not only does it install correctly (whereas 0.60 had problems), but replacing the copy of Module-Install in other failing modules corrects those failing installs. Those modules should only need to rebuild and re-release. (ref http://bugs.activestate.com/show_bug.cgi?id=45338)
Download (untitled) / with headers
text/plain 1.7k
On 2006-03-15 18:54:14 星期三, guest wrote: Show quoted text
> It has been verified (by myself and another) that Module-Install-
0.61 Show quoted text
> does work on ActivePerl on Windows. Not only does it install > correctly (whereas 0.60 had problems), but replacing the copy of > Module-Install in other failing modules corrects those failing > installs. Those modules should only need to rebuild and re-release. > > (ref http://bugs.activestate.com/show_bug.cgi?id=45338)
Module::Install 0.61 does work on ActivePerl 5.8.7 but breaks horribly on ActivePerl 5.8.8. The error messages are as follows. I really have no idea what is going on here and whose fault it is. CPAN.pm: Going to build S/SM/SMUELLER/PAR-Dist-0.08.tar.gz Undefined subroutine &ActivePerl::Config::find_prog called at E:/Perl/site/lib/A ctivePerl/Config.pm line 70. Compilation failed in require at E:/Perl/lib/ExtUtils/MakeMaker.pm line 7. BEGIN failed--compilation aborted at E:/Perl/lib/ExtUtils/MakeMaker.pm line 7. Compilation failed in require at inc/Module/Install/Can.pm - /usr/lib/perl5/site _perl/5.8.6/Module/Install/Can.pm line 11. BEGIN failed--compilation aborted at inc/Module/Install/Can.pm - /usr/lib/perl5/ site_perl/5.8.6/Module/Install/Can.pm line 11. Compilation failed in require at /home/tsee/data/perl/par/par2/PAR- Dist/inc/Modu le/Install.pm - /usr/lib/perl5/site_perl/5.8.6/Module/Install.pm line 180. Global symbol "$Verbose" requires explicit package name at E:/Perl/lib/ExtUtils/ MM_Any.pm line 1267. Global symbol "$Verbose" requires explicit package name at E:/Perl/lib/ExtUtils/ MM_Any.pm line 1277. Compilation failed in require at E:/Perl/lib/ExtUtils/MM_Unix.pm line 25. Compilation failed in require at inc/Module/Install/Metadata.pm - /usr/lib/perl5 /site_perl/5.8.6/Module/Install/Metadata.pm line 195.
Download (untitled) / with headers
text/plain 524b
On Sat Mar 25 07:36:11 2006, AGENT wrote: Show quoted text
> On 2006-03-15 18:54:14 星期三, guest wrote:
> > It has been verified (by myself and another) that Module-Install-
> Module::Install 0.61 does work on ActivePerl 5.8.7 but breaks
horribly Show quoted text
> on ActivePerl 5.8.8. The error messages are as follows. I really
have Show quoted text
> no idea what is going on here and whose fault it is. > > CPAN.pm: Going to build S/SM/SMUELLER/PAR-Dist-0.08.tar.gz
PAR-Dist-0.08.tar.gz does not contain Module-Install-0.61. It seems to use 0.56.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.