Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 18020
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: nospam-abuse [...] bloodgate.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.58
Fixed in: (no value)



Subject: Module::Install 0.58 borked
Please see http://rt.cpan.org/Ticket/Display.html?id=6558 at bottom: Quote jpo: Show quoted text
>Tels,
I think there is a problem with the latest version of Module::Install included with Image::Info 1.19 - I'm unable to generate the Makefile: ---------- $ perl Makefile.PL String found where operator expected at Makefile.PL line 89, near "name 'Image-Info'" (Do you need to predeclare name?) String found where operator expected at Makefile.PL line 94, near [snip errors] ---------- Show quoted text
>But if I add the following line, which existed in the previous version
of Module::Install, I'm able to generate it. ---------- $ diff -u Image-Info-1.19-orig/inc/Module/Install.pm Image-Info-1.19/inc/Module/ --- Image-Info-1.19-orig/inc/Module/Install.pm 2006-03-05 09:15:08.000000000 +0000 +++ Image-Info-1.19/inc/Module/Install.pm 2006-03-06 19:18:22.000000000 +0000 @@ -35,6 +35,8 @@ use File::Path (); use FindBin; +@inc::Module::Install::ISA = 'Module::Install'; + sub autoload { my $self = shift; my $who = $self->_caller; ---------- Best wishes, Tels
Subject: Re: [rt.cpan.org #18020] Module::Install 0.58 borked
Date: Tue, 07 Mar 2006 07:28:44 +0800
To: bug-Module-Install [...] rt.cpan.org
From: Audrey Tang <autrijus [...] gmail.com>
Try 0.59 and see if it works? Audrey
Download signature.asc
application/pgp-signature 187b

Message body not shown because it is not plain text.

From: jpo [...] di.uminho.pt
Download (untitled) / with headers
text/plain 452b
On Mon Mar 06 18:29:37 2006, autrijus@gmail.com wrote: Show quoted text
> Try 0.59 and see if it works? > > Audrey >
Appears to be working correctly. I have just replaced Image-Info 1.19 inc subdirectory by the one shipped with Module-Install 0.59 and I was able to execute the following commands without any problems: perl Makefile.PL make make test /jpo PS - The lib/Module/Install.pod has several lines "\r\n" terminated (check lines 650 to 668)
Fixed long term too now, and added extra documentation to stop it happening again.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.