This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
17998
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
adamk [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Wishlist
Broken in:
1.87
Fixed in:
(no value)



Subject: Add a generic capability to force upgrades
For background see http://use.perl.org/~Alias/journal/28855 As discussed in the above URI, one of the three patterns for installers requires that the installation infrstructure itself is forced to upgrade as soon as possible. Module::Build is the main candidate for needing this sort of features, although they may well do it themselves. ExtUtils::Install on Win32 is another example. While not yet of critical need, it may be worth examining what it would take to add general forced-upgrade support to CPAN.pm for a limited number of modules (for example, those in Bundle::CPAN at the most).
CC: Ken Williams <ken@forum.swarthmore.edu>
Subject: Re: [rt.cpan.org #17998] Add a generic capability to force upgrades
Date: Mon, 06 Mar 2006 08:15:41 +0100
To: bug-CPAN@rt.cpan.org
From: andreas.koenig.gmwojprw@franz.ak.mind.de (Andreas J. Koenig)
Show quoted text
>>>>> On Sun, 5 Mar 2006 12:55:46 -0500 (EST), " via RT" <bug-CPAN@rt.cpan.org> said:
Show quoted text
> Sun Mar 05 12:55:45 2006: Request 17998 was acted upon. > Transaction: Ticket created by ADAMK > Queue: CPAN > Subject: Add a generic capability to force upgrades > Owner: Nobody > Requestors: ADAMK@cpan.org > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=17998 >
Show quoted text
Show quoted text
> As discussed in the above URI, one of the three patterns for installers > requires that the installation infrstructure itself is forced to upgrade > as soon as possible.
Show quoted text
> Module::Build is the main candidate for needing this sort of features, > although they may well do it themselves.
Show quoted text
> ExtUtils::Install on Win32 is another example.
Show quoted text
> While not yet of critical need, it may be worth examining what it would > take to add general forced-upgrade support to CPAN.pm for a limited > number of modules (for example, those in Bundle::CPAN at the most).
If Ken confirms that, say, 0.2612 should be the minimum requirement, I think I know how to enfore this requirement in CPAN.pm exactly at that moment where Module::Build is actually about to be required. Just say the word, Ken:) All other modules in Bundle::CPAN are optional, so need no enforcement. (For the problem child ReadLine we have a separate ticket.) -- andreas
There seems no need to keep this open. I'd like to clean up open tickets now. Feel free to reopen if needed:)


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.