Skip Menu |
 

This queue is for tickets about the YAML-Syck CPAN distribution.

Report information
The Basics
Id: 17757
Status: resolved
Priority: 0/
Queue: YAML-Syck

People
Owner: Nobody in particular
Requestors: BARBIE [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: Windows/Perl 5.6.1 & utf8
Download (untitled) / with headers
text/plain 649b
There is a requirement to use utf8::encode within the code, via t\01_json.t. As a result I get: Undefined subroutine &utf8::encode called at t\01_json.t line 52. # Looks like your test died before it could output anything. Failed 1/2 test scripts, 50.00% okay. 42/43 subtests failed, 2.33% okay. NMAKE : fatal error U1077: 'C:\WINNT\system32\cmd.exe' : return code '0x2' Stop. This also applies to JSON. Is it possible to omit the utf8 testing? Tested on Windows 2000 Pro + ActivePerl 5.6.1. The function utf8::encode doesn't exist in Perl 5.6.1, so you may want to add 'use 5.008' in your Makefile.PL to ensure that only 5.8.x perls can use this.
Subject: Re: [rt.cpan.org #17757] Windows/Perl 5.6.1 & utf8
Date: Mon, 20 Feb 2006 15:44:22 -0800
To: bug-JSON-Syck [...] rt.cpan.org
From: "Tatsuhiko Miyagawa" <miyagawa [...] gmail.com>
OK, I'll add use 5.008 in Makefile.PL On 2/20/06, Barbie via RT <bug-JSON-Syck@rt.cpan.org> wrote: Show quoted text
> > Mon Feb 20 12:09:34 2006: Request 17757 was acted upon. > Transaction: Ticket created by BARBIE > Queue: JSON-Syck > Subject: Windows/Perl 5.6.1 & utf8 > Owner: Nobody > Requestors: BARBIE@cpan.org > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=17757 > > > > There is a requirement to use utf8::encode within the code, via > t\01_json.t. As a result I get: > > Undefined subroutine &utf8::encode called at t\01_json.t line 52. > # Looks like your test died before it could output anything. > Failed 1/2 test scripts, 50.00% okay. 42/43 subtests failed, 2.33% okay. > NMAKE : fatal error U1077: 'C:\WINNT\system32\cmd.exe' : return code '0x2' > Stop. > > This also applies to JSON. Is it possible to omit the utf8 testing? > Tested on Windows 2000 Pro + ActivePerl 5.6.1. The function utf8::encode > doesn't exist in Perl 5.6.1, so you may want to add 'use 5.008' in your > Makefile.PL to ensure that only 5.8.x perls can use this. >
-- Tatsuhiko Miyagawa
Miyagawa bumped perl dependency. Issue resolved.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.