This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
17706
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
ANDK [...] cpan.org
Requestors:
adamk [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
(no value)
Fixed in:
(no value)



Subject: Having YAML in Bundle::CPAN introduces a 5.6.1 dependency
After running the Bundle and noticing that Bundle::CPAN installs YAML, Test::Base and Spiffy, it occured to me there might be some version issues there. It would seem that all three of these have perl version dependencies of 5.6.1. Does this mean CPAN.pm can't be upgraded on 5.005 or older boxes now? Not sure if this is really a bug, or whether it should be a bug of YAML.pm et al, but I thought this would make a good enough starting point.
Subject: Re: [rt.cpan.org #17706] Having YAML in Bundle::CPAN introduces a 5.6.1 dependency
Date: Sat, 18 Feb 2006 10:25:47 +0100
To: bug-CPAN@rt.cpan.org
From: andreas.koenig.gmwojprw@franz.ak.mind.de (Andreas J. Koenig)
Show quoted text
>>>>> On Fri, 17 Feb 2006 14:01:57 -0500 (EST), " via RT" <bug-CPAN@rt.cpan.org> said:
Show quoted text
> Fri Feb 17 14:01:57 2006: Request 17706 was acted upon. > Transaction: Ticket created by ADAMK > Queue: CPAN > Subject: Having YAML in Bundle::CPAN introduces a 5.6.1 dependency > Owner: Nobody > Requestors: ADAMK@cpan.org > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=17706 >
Show quoted text
> After running the Bundle and noticing that Bundle::CPAN installs YAML, > Test::Base and Spiffy, it occured to me there might be some version > issues there.
Show quoted text
> It would seem that all three of these have perl version dependencies of > 5.6.1.
Show quoted text
> Does this mean CPAN.pm can't be upgraded on 5.005 or older boxes now?
CPAN.pm runs fine without the Bundle::CPAN, I regularly test it on 5.004_05. I would believe that people who are running these old versions are aware of that, but I can add a paragraph to CPAN.pm. [time passes] Done. =================================================================== --- lib/CPAN.pm (revision 616) +++ lib/CPAN.pm (working copy) @@ -6766,10 +6766,24 @@ of a modern rewrite from ground up with greater extensibility and more features but no full compatibility. If you're new to CPAN.pm, you probably should investigate if CPANPLUS is the better choice for you. -If you're already used to CPAN.pm you're welcome to continue using it, -if you accept that its development is mostly (though not completely) -stalled. +If you're already used to CPAN.pm you're welcome to continue using it. +I intend to support it until somebody convinces me that there is a +both superior and sufficiently compatible drop-in replacement. + +=head1 COMPATIBILITY + +CPAN.pm is regularly tested to run under 5.004, 5.005, and assorted +newer versions. It is getting more and more difficult to get the +minimal prerequisites working on older perls. It is close to +impossible to get the whole Bundle::CPAN working there. If you're in +the position to have only these old versions, be advised that CPAN is +designed to work fine without the Bundle::CPAN installed. + +To get things going, note that GBARR/Scalar-List-Utils-1.18.tar.gz is +compatible with ancient perls and that File::Temp is listed as a +prerequisite but CPAN has reasonable workarounds if it is missing. + =head1 DESCRIPTION -- andreas
Subject: Re: [rt.cpan.org #17706] Having YAML in Bundle::CPAN introduces a 5.6.1 dependency
Date: Sat, 18 Feb 2006 20:31:17 +1100
To: bug-CPAN@rt.cpan.org
From: Adam Kennedy <adam@phase-n.com>
Also, Ingy is going to take a look at the whole YAML/Test::Base/Spiffy 5.6.1 tomorrow I believe, and pull it/them back to at least 5.005_03. Adam K andreas.koenig.gmwojprw@franz.ak.mind.de via RT wrote:
Show quoted text
>>>>>> On Fri, 17 Feb 2006 14:01:57 -0500 (EST), " via RT" <bug-CPAN@rt.cpan.org> said:
>
> > Fri Feb 17 14:01:57 2006: Request 17706 was acted upon. > > Transaction: Ticket created by ADAMK > > Queue: CPAN > > Subject: Having YAML in Bundle::CPAN introduces a 5.6.1 dependency > > Owner: Nobody > > Requestors: ADAMK@cpan.org > > Status: new > > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=17706 >
> >
> > After running the Bundle and noticing that Bundle::CPAN installs YAML, > > Test::Base and Spiffy, it occured to me there might be some version > > issues there.
>
> > It would seem that all three of these have perl version dependencies of > > 5.6.1.
>
> > Does this mean CPAN.pm can't be upgraded on 5.005 or older boxes now?
> > CPAN.pm runs fine without the Bundle::CPAN, I regularly test it on > 5.004_05. I would believe that people who are running these old > versions are aware of that, but I can add a paragraph to CPAN.pm. > > [time passes] > > Done. > > =================================================================== > --- lib/CPAN.pm (revision 616) > +++ lib/CPAN.pm (working copy) > @@ -6766,10 +6766,24 @@ > of a modern rewrite from ground up with greater extensibility and more > features but no full compatibility. If you're new to CPAN.pm, you > probably should investigate if CPANPLUS is the better choice for you. > -If you're already used to CPAN.pm you're welcome to continue using it, > -if you accept that its development is mostly (though not completely) > -stalled. > > +If you're already used to CPAN.pm you're welcome to continue using it. > +I intend to support it until somebody convinces me that there is a > +both superior and sufficiently compatible drop-in replacement. > + > +=head1 COMPATIBILITY > + > +CPAN.pm is regularly tested to run under 5.004, 5.005, and assorted > +newer versions. It is getting more and more difficult to get the > +minimal prerequisites working on older perls. It is close to > +impossible to get the whole Bundle::CPAN working there. If you're in > +the position to have only these old versions, be advised that CPAN is > +designed to work fine without the Bundle::CPAN installed. > + > +To get things going, note that GBARR/Scalar-List-Utils-1.18.tar.gz is > +compatible with ancient perls and that File::Temp is listed as a > +prerequisite but CPAN has reasonable workarounds if it is missing. > + > =head1 DESCRIPTION > >


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.