This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
17701
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
adamk [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
(no value)
Fixed in:
(no value)



Subject: Vanilla Perl 5.8.8 fails to update to 1.84
Another failure to get 1.84 installed, this time with Vanilla Perl. Specifically this time, I got most of the Bundle stuff installed (although still seeing the same bundle errors reported in CamelPack 5.6) but the 1.84 install itself died. CPAN.pm: Going to build A/AN/ANDK/CPAN-1.84.tar.gz Checking if your kit is complete... Looks good Writing Makefile for CPAN dmake.EXE: makefile: line 959: Error: -- Cannot mix single and group recipe l ines C:\vanilla-perl\bin\dmake.EXE -- NOT OK Running make test Can't test without successful make Running make install make had returned bad status, install seems impossible
Show quoted text
cpan>
Not entirely sure what that means... but it doesn't look good. Have you thought about converting Bundle::CPAN to Task::CPAN? A little self-promotional, but it might removed Bundle issues. Of course, it could well add additional Module::Install issues :/ Adam K
Subject: Re: [rt.cpan.org #17701] Vanilla Perl 5.8.8 fails to update to 1.84
Date: Sat, 18 Feb 2006 08:40:35 +0100
To: bug-CPAN@rt.cpan.org
From: andreas.koenig.gmwojprw@franz.ak.mind.de (Andreas J. Koenig)
Show quoted text
>>>>> On Fri, 17 Feb 2006 12:23:49 -0500 (EST), " via RT" <bug-CPAN@rt.cpan.org> said:
Show quoted text
> Fri Feb 17 12:23:48 2006: Request 17701 was acted upon. > Transaction: Ticket created by ADAMK > Queue: CPAN > Subject: Vanilla Perl 5.8.8 fails to update to 1.84 > Owner: Nobody > Requestors: ADAMK@cpan.org > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=17701 >
Show quoted text
> Another failure to get 1.84 installed, this time with Vanilla Perl.
Show quoted text
> Specifically this time, I got most of the Bundle stuff installed > (although still seeing the same bundle errors reported in CamelPack 5.6) > but the 1.84 install itself died.
Show quoted text
> CPAN.pm: Going to build A/AN/ANDK/CPAN-1.84.tar.gz
Show quoted text
> Checking if your kit is complete... > Looks good > Writing Makefile for CPAN > dmake.EXE: makefile: line 959: Error: -- Cannot mix single and group > recipe l > ines
Please show me the lines around line 959. I suspect it as something to do with single and double colons. I will try this fix: Index: Makefile.PL =================================================================== --- Makefile.PL (revision 614) +++ Makefile.PL (working copy) @@ -5,6 +5,8 @@ use File::Path; eval { require File::Spec; }; my $HAVE_FILE_SPEC = !$@; +require Config; +my $HAVE_MAKE = $Config::Config{make} eq "make"; # file-scoped! use strict; use vars qw($VERSION); @@ -158,6 +160,7 @@ } sub postamble { + return unless $HAVE_MAKE; # dmake has unknown issues with my Makfile q{ setversion: $(PERL) Makefile.PL --setversion __EOPATCH__
Show quoted text
> C:\vanilla-perl\bin\dmake.EXE -- NOT OK > Running make test > Can't test without successful make > Running make install > make had returned bad status, install seems impossible
Show quoted text
cpan>
Show quoted text
> Not entirely sure what that means... but it doesn't look good.
Show quoted text
> Have you thought about converting Bundle::CPAN to Task::CPAN? A little > self-promotional, but it might removed Bundle issues.
Thanks, no. I do have to fix the bundle issue anyway, there are hundreds of other bundles that might suffer from the same bug. I do like your Task aproach though if I haven't yet told you.
Show quoted text
> Of course, it could well add additional Module::Install issues :/
-- andreas
Subject: Re: [rt.cpan.org #17701] Vanilla Perl 5.8.8 fails to update to 1.84
Date: Sat, 18 Feb 2006 19:31:32 +1100
To: bug-CPAN@rt.cpan.org
From: Adam Kennedy <adam@phase-n.com>
The only flaw I've found in Task:: so far (it only occured to me as I was dealing with the bundle problems) is that Task has "at least version" deps, whereas Bundles always update to the newest. I'll need to look into to more. But then I have intentionally not been promoting Task:: yet publically until I'm really happy that Module::Install is relatively bulletproof. Adam K andreas.koenig.gmwojprw@franz.ak.mind.de via RT wrote:
Show quoted text
>>>>>> On Fri, 17 Feb 2006 12:23:49 -0500 (EST), " via RT" <bug-CPAN@rt.cpan.org> said:
>
> > Fri Feb 17 12:23:48 2006: Request 17701 was acted upon. > > Transaction: Ticket created by ADAMK > > Queue: CPAN > > Subject: Vanilla Perl 5.8.8 fails to update to 1.84 > > Owner: Nobody > > Requestors: ADAMK@cpan.org > > Status: new > > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=17701 >
> >
> > Another failure to get 1.84 installed, this time with Vanilla Perl.
>
> > Specifically this time, I got most of the Bundle stuff installed > > (although still seeing the same bundle errors reported in CamelPack 5.6) > > but the 1.84 install itself died.
>
> > CPAN.pm: Going to build A/AN/ANDK/CPAN-1.84.tar.gz
>
> > Checking if your kit is complete... > > Looks good > > Writing Makefile for CPAN > > dmake.EXE: makefile: line 959: Error: -- Cannot mix single and group > > recipe l > > ines
> > > Please show me the lines around line 959. I suspect it as something to > do with single and double colons. I will try this fix: > > Index: Makefile.PL > =================================================================== > --- Makefile.PL (revision 614) > +++ Makefile.PL (working copy) > @@ -5,6 +5,8 @@ > use File::Path; > eval { require File::Spec; }; > my $HAVE_FILE_SPEC = !$@; > +require Config; > +my $HAVE_MAKE = $Config::Config{make} eq "make"; # file-scoped! > use strict; > use vars qw($VERSION); > > @@ -158,6 +160,7 @@ > } > > sub postamble { > + return unless $HAVE_MAKE; # dmake has unknown issues with my Makfile > q{ > setversion: > $(PERL) Makefile.PL --setversion > > > __EOPATCH__ > >
> > C:\vanilla-perl\bin\dmake.EXE -- NOT OK > > Running make test > > Can't test without successful make > > Running make install > > make had returned bad status, install seems impossible
>
> cpan>
>
> > Not entirely sure what that means... but it doesn't look good.
>
> > Have you thought about converting Bundle::CPAN to Task::CPAN? A little > > self-promotional, but it might removed Bundle issues.
> > Thanks, no. I do have to fix the bundle issue anyway, there are > hundreds of other bundles that might suffer from the same bug. I do > like your Task aproach though if I haven't yet told you. >
> > Of course, it could well add additional Module::Install issues :/
>
Subject: Re: [rt.cpan.org #17701] Vanilla Perl 5.8.8 fails to update to 1.84
Date: Sun, 19 Feb 2006 00:25:22 +1100
To: bug-CPAN@rt.cpan.org
From: Adam Kennedy <adam@phase-n.com>
OK, next here is the dmake.exe issue. dmake.EXE: makefile: line 959: Error: -- Cannot mix single and group recipe lines 957: 958: testshell-with-protocol: 959: [ -d protocols ] || mkdir protocols 960: $(MAKE) test TEST_FILES=t/30shell.t TEST_VERBOSE=1 | tee protocols/make-test-`date +%Y%m%dT%H%M%S` 961: ls -ltr protocols | tail 962: Beyond giving you that, I got nothing. My knowledge of make is negligable. But I hope that helps. Adam K andreas.koenig.gmwojprw@franz.ak.mind.de via RT wrote:
Show quoted text
>>>>>> On Fri, 17 Feb 2006 12:23:49 -0500 (EST), " via RT" <bug-CPAN@rt.cpan.org> said:
>
> > Fri Feb 17 12:23:48 2006: Request 17701 was acted upon. > > Transaction: Ticket created by ADAMK > > Queue: CPAN > > Subject: Vanilla Perl 5.8.8 fails to update to 1.84 > > Owner: Nobody > > Requestors: ADAMK@cpan.org > > Status: new > > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=17701 >
> >
> > Another failure to get 1.84 installed, this time with Vanilla Perl.
>
> > Specifically this time, I got most of the Bundle stuff installed > > (although still seeing the same bundle errors reported in CamelPack 5.6) > > but the 1.84 install itself died.
>
> > CPAN.pm: Going to build A/AN/ANDK/CPAN-1.84.tar.gz
>
> > Checking if your kit is complete... > > Looks good > > Writing Makefile for CPAN > > dmake.EXE: makefile: line 959: Error: -- Cannot mix single and group > > recipe l > > ines
> > > Please show me the lines around line 959. I suspect it as something to > do with single and double colons. I will try this fix: > > Index: Makefile.PL > =================================================================== > --- Makefile.PL (revision 614) > +++ Makefile.PL (working copy) > @@ -5,6 +5,8 @@ > use File::Path; > eval { require File::Spec; }; > my $HAVE_FILE_SPEC = !$@; > +require Config; > +my $HAVE_MAKE = $Config::Config{make} eq "make"; # file-scoped! > use strict; > use vars qw($VERSION); > > @@ -158,6 +160,7 @@ > } > > sub postamble { > + return unless $HAVE_MAKE; # dmake has unknown issues with my Makfile > q{ > setversion: > $(PERL) Makefile.PL --setversion > > > __EOPATCH__ > >
> > C:\vanilla-perl\bin\dmake.EXE -- NOT OK > > Running make test > > Can't test without successful make > > Running make install > > make had returned bad status, install seems impossible
>
> cpan>
>
> > Not entirely sure what that means... but it doesn't look good.
>
> > Have you thought about converting Bundle::CPAN to Task::CPAN? A little > > self-promotional, but it might removed Bundle issues.
> > Thanks, no. I do have to fix the bundle issue anyway, there are > hundreds of other bundles that might suffer from the same bug. I do > like your Task aproach though if I haven't yet told you. >
> > Of course, it could well add additional Module::Install issues :/
>
Subject: Re: [rt.cpan.org #17701] Vanilla Perl 5.8.8 fails to update to 1.84
Date: Sun, 19 Feb 2006 00:28:24 +1100
To: bug-CPAN@rt.cpan.org
From: Adam Kennedy <adam@phase-n.com>
Show quoted text
>> > Have you thought about converting Bundle::CPAN to Task::CPAN? A little >> > self-promotional, but it might removed Bundle issues.
>> >> Thanks, no. I do have to fix the bundle issue anyway, there are >> hundreds of other bundles that might suffer from the same bug. I do >> like your Task aproach though if I haven't yet told you.
Looks like the bundle problem is only a problem if the manifest contains another file of the same name below the bundle in the list. There's probably some CPAN::Mini::Expand script one could use to detect if any bundles have that problem, but since they are practically ALWAYS in a seperate dist, I think the impact will be minimal. Adam K


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.