Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 17661
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: MERLYN [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.27_07
Fixed in: (no value)



Download (untitled) / with headers
text/plain 549b
Show quoted text
cpan> r /Build/
Could not eval ' package ExtUtils::MakeMaker::_version; no strict; local $Pod::Text::VERSION; $Pod::Text::VERSION=undef; do { if $Pod::Text::VERSION == 3.01; }; $Pod::Text::VERSION ' in /opt/perl/snap/lib/site_perl/5.8.8/Module/Build/Base.pm: syntax error at (eval 4872) line 7, near "if $Pod::Text::VERSION " Apparently, you're tripping the "find me the version number" code in CPAN.pm by the way you've written your code. Please fix.
Download (untitled) / with headers
text/plain 188b
That's actually the version-finding code in ExtUtils::MakeMaker, not in CPAN.pm. I believe this was fixed in recent EU::MM versions too. But I'll obfuscate the line in M::B too. -Ken


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.