Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the WWW-Mechanize CPAN distribution.

Report information
The Basics
Id: 17123
Status: rejected
Priority: 0/
Queue: WWW-Mechanize

People
Owner: Nobody in particular
Requestors: Subrahmanian.Kalyanasundaram [...] igate.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: SEGMENTATION FAULT
Date: Wed, 18 Jan 2006 11:16:03 +0530
To: <bug-WWW-Mechanize [...] rt.cpan.org>
From: "Subrahmanian Kalyanasundaram" <Subrahmanian.Kalyanasundaram [...] igate.com>
Download (untitled) / with headers
text/plain 2.5k
Hi, I have a problem in executing the perl program, it is showing as "Segmentation Fault"..the thing happened, my environment is Sun solaris os - Ver 5.8 Perl - Ver 5.8.7 GCC - Ver 3.4.2 Crypt-SSLeay - Ver 0.51 Net_SSLeay- Ver 1.30 IO-Socket-SSL- Ver 0.97 I am trying to execute the WWW:Mechanizer program for that i have installed the "Crypt::SSleay" and while executing the program it is showing error as "Crypt::SSleay not installed", and we upgraded the gcc(version 3.4.2) and reinstalled the "Crypt::SSleay" and "Net::SSleay" and "IO" after this when i execute the program it is showing as "Segmentation fault" ############################################################### my perl program is ############################################################### #!/usr/bin/perl use WWW::Mechanize; use LWP::Debug qw(+); $url = 'https://my.igate.com/psp/IGATE/?cmd=login'; my $mechanize = WWW::Mechanize->new(autocheck => 1); $mechanize->get($url); my $page = $mechanize->content; print $page; ############################################################### The output is ############################################################### LWP::UserAgent::new: () LWP::UserAgent::request: () HTTP::Cookies::add_cookie_header: Checking my.igate.com for cookies HTTP::Cookies::add_cookie_header: Checking .igate.com for cookies HTTP::Cookies::add_cookie_header: Checking igate.com for cookies HTTP::Cookies::add_cookie_header: Checking .com for cookies LWP::UserAgent::send_request: GET https://my.igate.com/psp/IGATE/?cmd=login LWP::UserAgent::_need_proxy: Not proxied LWP::Protocol::http::request: () Segmentation Fault ############################################################### can u help me out, why the program is not executing any patches or modules need to be installed Thanks in advance Regards K.Subrahmanian _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ Information transmitted by this EMAIL is proprietary to iGATE Group of Companies and is intended for use only by the individual or entity to whom it is addressed and may contain information that is privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient of this EMAIL immediately notify the sender at iGATE or mailadmin@igate.com and delete this EMAIL including any attachments _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
Subject: Re: [rt.cpan.org #17123] SEGMENTATION FAULT
Date: Wed, 18 Jan 2006 09:36:56 -0500
To: Subrahmanian Kalyanasundaram via RT <bug-WWW-Mechanize [...] rt.cpan.org>
From: Mark Stosberg <mark [...] summersault.com>
Download (untitled) / with headers
text/plain 1.3k
On Wed, Jan 18, 2006 at 12:46:51AM -0500, Subrahmanian Kalyanasundaram via RT wrote: Show quoted text
> I have a problem in executing the perl program, it is showing as "Segmentation Fault"..the thing happened, > my environment is > > Sun solaris os - Ver 5.8 > Perl - Ver 5.8.7 > GCC - Ver 3.4.2 > Crypt-SSLeay - Ver 0.51 > Net_SSLeay- Ver 1.30 > IO-Socket-SSL- Ver 0.97 > > I am trying to execute the WWW:Mechanizer program for that i have installed the "Crypt::SSleay" > and while executing the program it is showing error as "Crypt::SSleay not installed", > and we upgraded the gcc(version 3.4.2) and reinstalled the "Crypt::SSleay" and "Net::SSleay" > and "IO" after this when i execute the program it is showing as "Segmentation fault"
I don't think this a bug in WWW::Mechanize, but one of the underlying modules that have "XS" code. I believe you are right to think that the gcc and "SSL" libraries may be related. Something very much like this happened to me once after I upgraded an low level SSL library. I never solved it, and downgraded the SSL library. I suggest asking for help on a mailing list related to one of the SSL projects or even on PerlMonks.org. However, I think this bug report for Mechanize should be considered "resolved", as I suspect you can reduce the problem further by creating a test script that exposes the bug without involving WWW::Mechanize at all. Mark
This sounds like an instlal problem more than anything.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.