Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the PPI CPAN distribution.

Report information
The Basics
Id: 16973
Status: resolved
Priority: 0/
Queue: PPI

People
Owner: Nobody in particular
Requestors: agentz [...] tom.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.109
Fixed in: (no value)



Subject: PPI 1.109 shouldn't require List::Util 1.18
Download (untitled) / with headers
text/plain 429b
Greetings. The latest version of PPI (v1.109) requires List::Util 1.18, which is known broken on Win32 build of Perl (even the lastest ActivePerl 5.8.7). The XS part of List::Util 1.18 makes use of the Perl_seed which is unpublic in the Win32 build. However, List::Util 1.17 works fine and all the tests shipped with PPI 1.109 are passed on my Windows 2000 if I modify the required version of List::Util to 1.17. Regards, Agent


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.