Skip Menu |
 

This queue is for tickets about the Jifty-DBI CPAN distribution.

Report information
The Basics
Id: 16936
Status: resolved
Priority: 0/
Queue: Jifty-DBI

People
Owner: Nobody in particular
Requestors: stephen [...] sydney.pm.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.09
Fixed in: (no value)



Subject: t/10schema.t in Jifty::DBI 0.09 requires DBIx::DBSchema >= 0.28 for SQLite support
Hi Jesse, Jifty::DBI 0.09 fails test t/10schema.t when: - DBD::SQLite is installed - DBIx::DBSchema < 0.28 is installed (does not include SQLite support) The @available_drivers setup in t/utils.pl only checks for DBD::* and not the matching DBIx::DBSchema::DBD::* driver; also no minimum version of DBIx::DBSchema is specified. Patches for both issues follow. Cheers, Stephen --- Jifty-DBI-0.09/Makefile.PL.dist 2005-12-29 23:47:41.000000000 +1100 +++ Jifty-DBI-0.09/Makefile.PL 2006-01-07 00:20:02.000000000 +1100 @@ -24,7 +24,7 @@ features( 'Schema generation' => [ -default => 1, - 'DBIx::DBSchema' => '', + 'DBIx::DBSchema' => '0.28', 'Class::Accessor' => '', ], ); --- Jifty-DBI-0.09/t/utils.pl.dist 2005-11-09 07:33:00.000000000 +1100 +++ Jifty-DBI-0.09/t/utils.pl 2006-01-07 00:09:37.000000000 +1100 @@ -30,6 +30,7 @@ =cut our @available_drivers = grep { eval "require DBD::". $_ } @supported_drivers; +@available_drivers = grep { eval "require DBIx::DBSchema::DBD::" . $_ } @available_drivers; =head1 functionS
Date: Sun, 8 Jan 2006 05:13:39 -0500
From: jesse <jesse [...] fsck.com>
To: Guest via RT <bug-Jifty-DBI [...] rt.cpan.org>
Subject: Re: [cpan #16936] t/10schema.t in Jifty::DBI 0.09 requires DBIx::DBSchema >= 0.28 for SQLite support
RT-Send-Cc:
Download (untitled) / with headers
text/plain 1.5k
Thanks. 0.10 applies the first fix. The second one worries me a bit more, as it looks like it'll entirely break Jifty::DBI for databases that don't have schema support. On Fri, Jan 06, 2006 at 08:25:10AM -0500, Guest via RT wrote: Show quoted text
> > This message about Jifty-DBI was sent to you by guest <> via rt.cpan.org > > Full context and any attached attachments can be found at: > <URL: https://rt.cpan.org/Ticket/Display.html?id=16936 > > > Hi Jesse, > > Jifty::DBI 0.09 fails test t/10schema.t when: > - DBD::SQLite is installed > - DBIx::DBSchema < 0.28 is installed (does not include SQLite support) > > The @available_drivers setup in t/utils.pl only checks for DBD::* and not the matching DBIx::DBSchema::DBD::* driver; also no minimum version of DBIx::DBSchema is specified. > > Patches for both issues follow. > > Cheers, > Stephen > > --- Jifty-DBI-0.09/Makefile.PL.dist 2005-12-29 23:47:41.000000000 +1100 > +++ Jifty-DBI-0.09/Makefile.PL 2006-01-07 00:20:02.000000000 +1100 > @@ -24,7 +24,7 @@ > features( > 'Schema generation' => [ > -default => 1, > - 'DBIx::DBSchema' => '', > + 'DBIx::DBSchema' => '0.28', > 'Class::Accessor' => '', > ], > ); > > --- Jifty-DBI-0.09/t/utils.pl.dist 2005-11-09 07:33:00.000000000 +1100 > +++ Jifty-DBI-0.09/t/utils.pl 2006-01-07 00:09:37.000000000 +1100 > @@ -30,6 +30,7 @@ > =cut > > our @available_drivers = grep { eval "require DBD::". $_ } @supported_drivers; > +@available_drivers = grep { eval "require DBIx::DBSchema::DBD::" . $_ } @available_drivers; > > =head1 functionS >
--
From: stephen [...] sydney.pm.org
Download (untitled) / with headers
text/plain 503b
Show quoted text
> Thanks. 0.10 applies the first fix. The second one worries me a bit > more, as it looks like it'll entirely break Jifty::DBI for databases > that don't have schema support.
Hi Jesse, Oops, that will indeed skip some otherwise valid tests for available drivers. Think it does just want to be a patch for t/10schema.t, but probably much saner to properly update the prereqs ;). Admirably quick response on your RT tickets by the way .. you're several months ahead of the average! Cheers, Stephen
Date: Tue, 10 Jan 2006 19:58:09 +0100
From: Jesse Vincent <jesse [...] fsck.com>
To: bug-Jifty-DBI [...] rt.cpan.org
Subject: Re: [cpan #16936] t/10schema.t in Jifty::DBI 0.09 requires DBIx::DBSchema >= 0.28 for SQLite support
RT-Send-Cc:
Download (untitled) / with headers
text/plain 202b
Show quoted text
> > Admirably quick response on your RT tickets by the way .. you're several months ahead of > the average!
*laugh* That is why I created rt.cpan.org, after all. Jesse Show quoted text
> > Cheers, > Stephen >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.