Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 16787
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: rt-cpan [...] trout.me.uk
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.50
Fixed in: (no value)



Subject: No such method _top error installing under cygwin
Download (untitled) / with headers
text/plain 7.5k
Perl info - bash-3.00$ perl --version This is perl, v5.8.7 built for cygwin-thread-multi-64int Copyright 1987-2005, Larry Wall Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit. Complete documentation for Perl, including FAQ lists, should be found on this system using `man perl' or `perldoc perl'. If you have access to the Internet, point your browser at http://www.perl.org/, the Perl Home Page. bash-3.00$ perl -V Summary of my perl5 (revision 5 version 8 subversion 7) configuration: Platform: osname=cygwin, osvers=1.5.18(0.13242), archname=cygwin-thread-multi-64int uname='cygwin_nt-5.1 inspiron 1.5.18(0.13242) 2005-07-02 20:30 i686 unknown unknown cygwin ' config_args='-de -Dmksymlinks -Duse64bitint -Dusethreads -Uusemymalloc -Dopt imize=-O3 -Dman3ext=3pm -Dusesitecustomize' hint=recommended, useposix=true, d_sigaction=define usethreads=define use5005threads=undef useithreads=define usemultiplicity=de fine useperlio=define d_sfio=undef uselargefiles=define usesocks=undef use64bitint=define use64bitall=undef uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='gcc', ccflags ='-DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -I/usr /local/include', optimize='-O3', cppflags='-DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -I/usr/local/inc lude' ccversion='', gccversion='3.4.4 (cygming special) (gdc 0.12, using dmd 0.125 )', gccosandvers='' intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12 ivtype='long long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lsee ksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='ld2', ldflags =' -s -L/usr/local/lib' libpth=/usr/local/lib /usr/lib /lib libs=-lgdbm -ldb -lcrypt -lgdbm_compat perllibs=-lcrypt -lgdbm_compat libc=/usr/lib/libc.a, so=dll, useshrplib=true, libperl=libperl.a gnulibc_version='' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' -s' cccdlflags=' ', lddlflags=' -s -L/usr/local/lib' Characteristics of this binary (from libperl): Compile-time options: MULTIPLICITY USE_ITHREADS USE_64_BIT_INT USE_LARGE_FILES USE_SITECUSTOMIZE PERL_IMPLICIT_CONTEXT Built under cygwin Compiled at Aug 22 2005 22:02:21 %ENV: CYGWIN="" @INC: /usr/lib/perl5/5.8/cygwin /usr/lib/perl5/5.8 /usr/lib/perl5/site_perl/5.8/cygwin /usr/lib/perl5/site_perl/5.8 /usr/lib/perl5/site_perl/5.8 /usr/lib/perl5/vendor_perl/5.8/cygwin /usr/lib/perl5/vendor_perl/5.8 /usr/lib/perl5/vendor_perl/5.8 . Build log for SVK - CPAN.pm: Going to build C/CL/CLKAO/SVK-1.06.tar.gz *** Module::AutoInstall version 1.00 *** Checking for dependencies... [Core Features] - Algorithm::Annotate ...missing. - Algorithm::Diff ...missing. - YAML ...loaded. (0.39 >= 0.38) - Regexp::Shellish ...missing. - Data::Hierarchy ...missing. (would need 0.21) - File::Temp ...loaded. (0.16 >= 0.14) - Clone ...missing. - Pod::Escapes ...missing. - Pod::Simple ...missing. - PerlIO::via::dynamic ...missing. (would need 0.11) - PerlIO::via::symlink ...missing. (would need 0.02) - IO::Digest ...missing. - SVN::Simple::Edit ...missing. (would need 0.27) - Date::Parse ...missing. - File::Type ...missing. - URI ...missing. - PerlIO::eol ...missing. (would need 0.13) - Class::Autouse ...missing. (would need 1.15) - Getopt::Long ...loaded. (2.34 >= 2.34) - Encode ...loaded. (2.10 >= 2.10) ==> Auto-install the 16 mandatory module(s) from CPAN? [y] [Localized messages] - Locale::Maketext::Lexicon ...missing. (would need 0.42) - Locale::Maketext::Simple ...missing. (would need 0.12) ==> Auto-install the 2 optional module(s) from CPAN? [y] [Message display through a pager] - IO::Pager ...missing. ==> Auto-install the 1 optional module(s) from CPAN? [y] [SVN::Mirror support] - SVN::Mirror ...missing. (would need 0.66) ==> Auto-install the 1 optional module(s) from CPAN? [y] [Patch management] - Compress::Zlib ...loaded. (1.34) - FreezeThaw ...missing. ==> Auto-install the 1 optional module(s) from CPAN? [y] *** Since we're running under CPAN, I'll just let it take care of the dependency's installation later. *** Module::AutoInstall configuration finished. Checking if your kit is complete... Looks good Warning: prerequisite Algorithm::Annotate 0 not found. Warning: prerequisite Algorithm::Diff 0 not found. Warning: prerequisite Class::Autouse 1.15 not found. Warning: prerequisite Clone 0 not found. Warning: prerequisite Data::Hierarchy 0.21 not found. Warning: prerequisite Date::Parse 0 not found. Warning: prerequisite File::Type 0 not found. Warning: prerequisite FreezeThaw 0 not found. Warning: prerequisite IO::Digest 0 not found. Warning: prerequisite IO::Pager 0 not found. Warning: prerequisite Locale::Maketext::Lexicon 0.42 not found. Warning: prerequisite Locale::Maketext::Simple 0.12 not found. Warning: prerequisite PerlIO::eol 0.13 not found. Warning: prerequisite PerlIO::via::dynamic 0.11 not found. Warning: prerequisite PerlIO::via::symlink 0.02 not found. Warning: prerequisite Pod::Escapes 0 not found. Warning: prerequisite Pod::Simple 0 not found. Warning: prerequisite Regexp::Shellish 0 not found. Warning: prerequisite SVN::Mirror 0.66 not found. Warning: prerequisite SVN::Simple::Edit 0.27 not found. Warning: prerequisite URI 0 not found. Can't locate object method "_top" via package "PACK001" at inc/Module/Install/Ba se.pm - /usr/local/lib/perl5/site_perl/5.8.5/Module/Install/Base.pm line 52. Running make test Make had some problems, maybe interrupted? Won't test Running make install Make had some problems, maybe interrupted? Won't install Build log trying to upgrade Module::Install - CPAN.pm: Going to build A/AU/AUTRIJUS/Module-Install-0.50.tar.gz *** Module::AutoInstall version 1.00 *** Checking for dependencies... [Core Features] - YAML ...loaded. (0.39 >= 0.35) [Include packages with full dependencies] - Test::Harness ...loaded. (2.48 >= 2.03) - Test::More ...loaded. (0.62) - Module::ScanDeps ...missing. (would need 0.28) - Module::CoreList ...missing. ==> Auto-install the 2 optional module(s) from CPAN? [y] n [Bundle other CPAN packages] - CPANPLUS ...missing. (would need 0.04) ==> Auto-install the 1 optional module(s) from CPAN? [y] n [PAR-based binary distributions] - PAR::Dist ...missing. (would need 0.03) ==> Auto-install the 1 optional module(s) from CPAN? [y] n [Module::Build support] - Archive::Tar ...loaded. (1.24 >= 0.23) - ExtUtils::Install ...loaded. (1.33 >= 0.3) - ExtUtils::ParseXS ...missing. - Module::Build ...loaded. (0.2611) ==> Auto-install the 1 optional module(s) from CPAN? [y] n *** Module::AutoInstall configuration finished. Checking if your kit is complete... Looks good Can't locate object method "_top" via package "PACK001" at inc/Module/Install/Base.pm - lib/Module/Install/Base.pm line 51. # Looks like your test died before it could output anything. Running make test Make had some problems, maybe interrupted? Won't test Running make install Make had some problems, maybe interrupted? Won't install
From: mgrimes [...] cpan.org
Download (untitled) / with headers
text/plain 8.8k
I ran into the same bug. The problem is in Module::Install::Can # Fix Cygwin bug on maybe_command(); 00052 if ($^O eq 'cygwin') { 00053 require ExtUtils::MM_Cygwin; 00054 if (!defined(&ExtUtils::MM_Cygwin::maybe_command)) { 00055 *ExtUtils::MM_Cygwin::maybe_command = sub { 00056 my ($self, $file) = @_; 00057 if ($file =~ m{^/cygdrive/}i) { 00058 ExtUtils::MM_Win32->maybe_command($file); 00059 } 00060 else { 00061 $self->SUPER::maybe_command($file); 00062 } 00063 } 00064 } 00065 } If it drops to line 61 and attempts to call $self->SUPER it runs the AUTOLOAD function from Module::Install::Base. @ISA = (Module::Install::Base. It looks like @ISA should be ExtUtils::MM_Unix. Changing line 61 to the following worked for me: $self->ExtUtils::MM_Unix::maybe_command($file); # $self->SUPER::maybe_command($file); -Mark [guest - Thu Dec 29 10:41:18 2005]: Show quoted text
> Perl info - > > bash-3.00$ perl --version > > This is perl, v5.8.7 built for cygwin-thread-multi-64int > > Copyright 1987-2005, Larry Wall > > Perl may be copied only under the terms of either the Artistic License > or the > GNU General Public License, which may be found in the Perl 5 source > kit. > > Complete documentation for Perl, including FAQ lists, should be found > on > this system using `man perl' or `perldoc perl'. If you have access to > the > Internet, point your browser at http://www.perl.org/, the Perl Home > Page. > > bash-3.00$ perl -V > Summary of my perl5 (revision 5 version 8 subversion 7) configuration: > Platform: > osname=cygwin, osvers=1.5.18(0.13242), archname=cygwin-thread- > multi-64int > uname='cygwin_nt-5.1 inspiron 1.5.18(0.13242) 2005-07-02 20:30 > i686 unknown > unknown cygwin ' > config_args='-de -Dmksymlinks -Duse64bitint -Dusethreads > -Uusemymalloc -Dopt > imize=-O3 -Dman3ext=3pm -Dusesitecustomize' > hint=recommended, useposix=true, d_sigaction=define > usethreads=define use5005threads=undef useithreads=define > usemultiplicity=de > fine > useperlio=define d_sfio=undef uselargefiles=define usesocks=undef > use64bitint=define use64bitall=undef uselongdouble=undef > usemymalloc=n, bincompat5005=undef > Compiler: > cc='gcc', ccflags ='-DPERL_USE_SAFE_PUTENV -fno-strict-aliasing > -pipe -I/usr > /local/include', > optimize='-O3', > cppflags='-DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe > -I/usr/local/inc > lude' > ccversion='', gccversion='3.4.4 (cygming special) (gdc 0.12, using > dmd 0.125 > )', gccosandvers='' > intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678 > d_longlong=define, longlongsize=8, d_longdbl=define, > longdblsize=12 > ivtype='long long', ivsize=8, nvtype='double', nvsize=8, > Off_t='off_t', lsee > ksize=8 > alignbytes=8, prototype=define > Linker and Libraries: > ld='ld2', ldflags =' -s -L/usr/local/lib' > libpth=/usr/local/lib /usr/lib /lib > libs=-lgdbm -ldb -lcrypt -lgdbm_compat > perllibs=-lcrypt -lgdbm_compat > libc=/usr/lib/libc.a, so=dll, useshrplib=true, libperl=libperl.a > gnulibc_version='' > Dynamic Linking: > dlsrc=dl_dlopen.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' -s' > cccdlflags=' ', lddlflags=' -s -L/usr/local/lib' > > > Characteristics of this binary (from libperl): > Compile-time options: MULTIPLICITY USE_ITHREADS USE_64_BIT_INT > USE_LARGE_FILES USE_SITECUSTOMIZE > PERL_IMPLICIT_CONTEXT > Built under cygwin > Compiled at Aug 22 2005 22:02:21 > %ENV: > CYGWIN="" > @INC: > /usr/lib/perl5/5.8/cygwin > /usr/lib/perl5/5.8 > /usr/lib/perl5/site_perl/5.8/cygwin > /usr/lib/perl5/site_perl/5.8 > /usr/lib/perl5/site_perl/5.8 > /usr/lib/perl5/vendor_perl/5.8/cygwin > /usr/lib/perl5/vendor_perl/5.8 > /usr/lib/perl5/vendor_perl/5.8 > . > > Build log for SVK - > > > CPAN.pm: Going to build C/CL/CLKAO/SVK-1.06.tar.gz > > *** Module::AutoInstall version 1.00 > *** Checking for dependencies... > [Core Features] > - Algorithm::Annotate ...missing. > - Algorithm::Diff ...missing. > - YAML ...loaded. (0.39 >= 0.38) > - Regexp::Shellish ...missing. > - Data::Hierarchy ...missing. (would need 0.21) > - File::Temp ...loaded. (0.16 >= 0.14) > - Clone ...missing. > - Pod::Escapes ...missing. > - Pod::Simple ...missing. > - PerlIO::via::dynamic ...missing. (would need 0.11) > - PerlIO::via::symlink ...missing. (would need 0.02) > - IO::Digest ...missing. > - SVN::Simple::Edit ...missing. (would need 0.27) > - Date::Parse ...missing. > - File::Type ...missing. > - URI ...missing. > - PerlIO::eol ...missing. (would need 0.13) > - Class::Autouse ...missing. (would need 1.15) > - Getopt::Long ...loaded. (2.34 >= 2.34) > - Encode ...loaded. (2.10 >= 2.10) > ==> Auto-install the 16 mandatory module(s) from CPAN? [y] > [Localized messages] > - Locale::Maketext::Lexicon ...missing. (would need 0.42) > - Locale::Maketext::Simple ...missing. (would need 0.12) > ==> Auto-install the 2 optional module(s) from CPAN? [y] > [Message display through a pager] > - IO::Pager ...missing. > ==> Auto-install the 1 optional module(s) from CPAN? [y] > [SVN::Mirror support] > - SVN::Mirror ...missing. (would need 0.66) > ==> Auto-install the 1 optional module(s) from CPAN? [y] > [Patch management] > - Compress::Zlib ...loaded. (1.34) > - FreezeThaw ...missing. > ==> Auto-install the 1 optional module(s) from CPAN? [y] > > *** Since we're running under CPAN, I'll just let it take care > of the dependency's installation later. > *** Module::AutoInstall configuration finished. > Checking if your kit is complete... > Looks good > Warning: prerequisite Algorithm::Annotate 0 not found. > Warning: prerequisite Algorithm::Diff 0 not found. > Warning: prerequisite Class::Autouse 1.15 not found. > Warning: prerequisite Clone 0 not found. > Warning: prerequisite Data::Hierarchy 0.21 not found. > Warning: prerequisite Date::Parse 0 not found. > Warning: prerequisite File::Type 0 not found. > Warning: prerequisite FreezeThaw 0 not found. > Warning: prerequisite IO::Digest 0 not found. > Warning: prerequisite IO::Pager 0 not found. > Warning: prerequisite Locale::Maketext::Lexicon 0.42 not found. > Warning: prerequisite Locale::Maketext::Simple 0.12 not found. > Warning: prerequisite PerlIO::eol 0.13 not found. > Warning: prerequisite PerlIO::via::dynamic 0.11 not found. > Warning: prerequisite PerlIO::via::symlink 0.02 not found. > Warning: prerequisite Pod::Escapes 0 not found. > Warning: prerequisite Pod::Simple 0 not found. > Warning: prerequisite Regexp::Shellish 0 not found. > Warning: prerequisite SVN::Mirror 0.66 not found. > Warning: prerequisite SVN::Simple::Edit 0.27 not found. > Warning: prerequisite URI 0 not found. > Can't locate object method "_top" via package "PACK001" at > inc/Module/Install/Ba > se.pm - /usr/local/lib/perl5/site_perl/5.8.5/Module/Install/Base.pm > line 52. > Running make test > Make had some problems, maybe interrupted? Won't test > Running make install > Make had some problems, maybe interrupted? Won't install > > Build log trying to upgrade Module::Install - > > CPAN.pm: Going to build A/AU/AUTRIJUS/Module-Install-0.50.tar.gz > > *** Module::AutoInstall version 1.00 > *** Checking for dependencies... > [Core Features] > - YAML ...loaded. (0.39 >= 0.35) > [Include packages with full dependencies] > - Test::Harness ...loaded. (2.48 >= 2.03) > - Test::More ...loaded. (0.62) > - Module::ScanDeps ...missing. (would need 0.28) > - Module::CoreList ...missing. > ==> Auto-install the 2 optional module(s) from CPAN? [y] n > [Bundle other CPAN packages] > - CPANPLUS ...missing. (would need 0.04) > ==> Auto-install the 1 optional module(s) from CPAN? [y] n > [PAR-based binary distributions] > - PAR::Dist ...missing. (would need 0.03) > ==> Auto-install the 1 optional module(s) from CPAN? [y] n > [Module::Build support] > - Archive::Tar ...loaded. (1.24 >= 0.23) > - ExtUtils::Install ...loaded. (1.33 >= 0.3) > - ExtUtils::ParseXS ...missing. > - Module::Build ...loaded. (0.2611) > ==> Auto-install the 1 optional module(s) from CPAN? [y] n > *** Module::AutoInstall configuration finished. > Checking if your kit is complete... > Looks good > Can't locate object method "_top" via package "PACK001" at > inc/Module/Install/Base.pm - lib/Module/Install/Base.pm line 51. > # Looks like your test died before it could output anything. > Running make test > Make had some problems, maybe interrupted? Won't test > Running make install > Make had some problems, maybe interrupted? Won't install >
From: Will Hawes <info [...] whawes.co.uk>
Download (untitled) / with headers
text/plain 12.3k

Message body is not shown because it is too large.

From: Will Hawes <info [...] whawes.co.uk>
Download (untitled) / with headers
text/plain 279b
On Wed Apr 26 08:50:35 2006, guest wrote: Show quoted text
> I'm seeing something very similar, albeit with the latest, fixed > version > of Module::Install.
Sorry, scrub that - turns out it's actually a problem with Object::Signature. Deleting the /inc directory in that dist did the trick.
From my reading of the code in ::Can, this was fixed a while back.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.