Skip Menu |
 

This queue is for tickets about the Net-Google CPAN distribution.

Report information
The Basics
Id: 16384
Status: open
Priority: 0/
Queue: Net-Google

People
Owner: Nobody in particular
Requestors: flavio [...] polettix.it
Cc: Dan [...] DWright.Org
AdminCc:

Bug Information
Severity: Critical
Broken in: 1.0
Fixed in: (no value)



Subject: Test errors due to "missing" wsdl file
Download (untitled) / with headers
text/plain 683b
Net::Google v. 1.0 perl -v: This is perl, v5.8.6 built for i386-linux uname -a: Linux flaviox 2.4.20-flavio-qos #1 Mon Nov 10 13:03:54 CET 2003 i686 unknown [All paths below start from the main Net-Google-1.0 directory] File lib/Net/Google/Services/GoogleSearch.wsdl isn't copied inside blib/... during build phase. This makes t/00[123]* tests fail due to the absence of the WSDL file in the expected path under @INC; I solved this manually: * creating the Services directory in blib/lib/Net/Google * copying lib/Net/Google/Services/GoogleSearch.wsdl inside blib/lib/Net/Google/Services I don't have a patch to propose, simply because I don't know Module::Build - sorry for this.
From: william-bugtracker.cpan.org [...] scissor.com
Download (untitled) / with headers
text/plain 259b
On Fri Dec 09 05:04:49 2005, guest wrote: Show quoted text
> * creating the Services directory in blib/lib/Net/Google > * copying lib/Net/Google/Services/GoogleSearch.wsdl inside > blib/lib/Net/Google/Services >
Fantastic! That fixed the problem for me. Thanks for posting.
From: DWRIGHT [...] cpan.org
Download (untitled) / with headers
text/plain 764b
On Fri Dec 09 05:04:49 2005, guest wrote: Show quoted text
> File lib/Net/Google/Services/GoogleSearch.wsdl isn't copied inside > blib/... during build phase. This makes t/00[123]* tests fail due to > the absence of the WSDL file in the expected path under @INC; I solved > this manually:
Not only does it make the test fail, it keeps the module from working at all (unless you already have a previous copy of the wsdl in your @INC somewhere from a previous version of Net::Google) To reproduce: Remove all instances of GoogleSearch.wsdl from any location in your @INC, and try running the tests. Show quoted text
> I don't have a patch to propose, simply because I don't know > Module::Build - sorry for this.
Here's the patch to Build.PL: 21c21 < --- Show quoted text
> $build->add_build_element('wsdl');


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.