Skip Menu |
 

This queue is for tickets about the IO-Zlib CPAN distribution.

Report information
The Basics
Id: 16275
Status: resolved
Priority: 0/
Queue: IO-Zlib

People
Owner: Nobody in particular
Requestors: RandyS [...] ThePierianSpring.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Requirement on Fcntl (SEEK_SET)
Download (untitled) / with headers
text/plain 114b
IO::Zlib only requires perl 5.004, but it tries to import Fcntl::SEEK_SET which isn't defined until 5.6 (I think).
From: SREZIC [...] cpan.org
Download (untitled) / with headers
text/plain 430b
On Sat Dec 03 21:05:32 2005, guest wrote: Show quoted text
> IO::Zlib only requires perl 5.004, but it tries to import > Fcntl::SEEK_SET which isn't defined until 5.6 (I think).
I made a patch to make the Fcntl seek stuff optional for older perls. See here: http://www.cpan.org/authors/id/S/SR/SREZIC/patches/IO-Zlib-1.07-SREZIC-01.patch There are still some test failures in tied.t, but all other tests pass with the patch. Regards, Slaven
Fixed in 1.08 release - perl 5.6 is now required.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.