This queue is for tickets about the XML-LibXSLT CPAN distribution.

Report information
The Basics
Id:
15723
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
dmitry.kim [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
Critical
Broken in:
  • 1.57
  • 1.58
Fixed in:
(no value)



Subject: XML::LibXSLT v >= 1.57 breaks <xsl:import> for me
XML::LibXSLT versions 1.57 and 1.58 break <xsl:import /> for me. it worked ok with 1.53. i tried to specify base_uri parameter for XML::LibXML, but to no avail. i don't use callbacks. here's the test case, if any: -----(file t/13import.t)----- use Test; BEGIN { plan tests => 5 } END { ok(0) unless $loaded } use XML::LibXSLT; $loaded = 1; ok(1); my $x = XML::LibXML->new() ; ok($x) ; my $p = XML::LibXSLT->new(); ok($p); my $xsl = <<EOF <?xml version="1.0" encoding="UTF-8"?> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0"> <xsl:import href="example/2.xsl" /> <xsl:output method="html" /> </xsl:stylesheet> EOF ; my $xsld = $x->parse_string($xsl) ; ok($xsld) ; my $tr = $p->parse_stylesheet($xsld) ; ok($tr) ; -----(/file t/13import.t)---- with 1.53 i have:
Show quoted text
> t/13import.......ok
and with 1.57 and 1.58 i have:
Show quoted text
> t/13import.......ok 4/5compilation error: > file unknown-000135700992 element import > xsl:import : unable to load example/2.xsl t/13import.......NOK 5# > Failed test 5 in t/13import.t at line 22 > # t/13import.t line 22 is: ok($tr) ; > t/13import.......FAILED test 5
Last release (XML::LibXSLT 1.59) with libxslt 1.1.15 passes your test. Anyway, I added your test case as t/12import.t to the the axkit Subversion repository (to appear in 1.60 release). -- Petr


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.