Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the WWW-Mechanize CPAN distribution.

Report information
The Basics
Id: 15684
Status: resolved
Priority: 0/
Queue: WWW-Mechanize

People
Owner: Nobody in particular
Requestors: gerhard [...] gamecat.de
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.16
Fixed in: (no value)



Subject: t/back fails if Crypt::SSLeay is not installed
Download (untitled) / with headers
text/plain 927b
distribution: WWW-Mechanize-1.16 perl: perl, v5.8.7 built for i486-linux-gnu-thread-multi OS: Linux 2.6.12 #1 SMP Fri Nov 4 20:35:55 CET 2005 i686 GNU/Linux Important things first: thanx a lot for a great modul. I labeled this one 'important' because a test is failing. But it is almost too simple to fix it :) The 4th test in t/live/back.t tests if the attemtp to follow the second link on http://www.google.com/intl/en/ was successful. This link ("sign in") uses https. So the test fails if Crypt::SSLeay is not installed. You could probably: * just use the third link, since at the moment all other links don't use https (the simple solution) * detect if the link uses https and try to load Crypt::SSLeay on the fly (but if it is not installed you have to use the next link anyway). I would suggest the first one. A diff: 19c19 < $mech->follow_link( n=>3 ); --- Show quoted text
> $mech->follow_link( n=>2 );
Have a nice day, gerhard
Download (untitled) / with headers
text/plain 1.1k
Another possibility is to test on webpages the module author controls so the module's tests don't break if Google redesigns. [guest - Thu Nov 10 15:43:15 2005]: Show quoted text
> distribution: WWW-Mechanize-1.16 > perl: perl, v5.8.7 built for i486-linux-gnu-thread-multi > OS: Linux 2.6.12 #1 SMP Fri Nov 4 20:35:55 CET 2005 i686 GNU/Linux > > Important things first: thanx a lot for a great modul. > > I labeled this one 'important' because a test is failing. > But it is almost too simple to fix it :) > > The 4th test in t/live/back.t tests if the attemtp to follow the > second link on http://www.google.com/intl/en/ was successful. > This link ("sign in") uses https. > So the test fails if Crypt::SSLeay is not installed. > > You could probably: > * just use the third link, since at the moment all other links don't > use https (the simple solution) > * detect if the link uses https and try to load Crypt::SSLeay on the > fly (but if it is not installed you have to use the next link > anyway). > > I would suggest the first one. A diff: > 19c19 > < $mech->follow_link( n=>3 ); > ---
> > $mech->follow_link( n=>2 );
> > Have a nice day, > gerhard
Fixed in 1.18.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.