Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 15284
Status: resolved
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: LTHEGLER [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.10
Fixed in: (no value)



Subject: Perl 5.8-isms
Download (untitled) / with headers
text/plain 536b
Makefile.PL claims that it requires perl version 5.005, but there are a couple of things, that is specific for 5.8: 1) "use Exporter 'import'" - the 'improt' argument appeared in the Exporter bundled with 5.8.something. 5.6 does not support it. 2) Used with perls before 5.8.1, version.pm requires version strings, containing more than one dot (e.g. 5.8.4), to be quoted. So: version->new("5.5.3") instead of version->new(5.5.3) This impacts t/02_main.t. 3) PPI itself also contains constructs, limiting it to >= 5.6.1 /Lars


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.