Skip Menu |
 

This queue is for tickets about the Test-TAP-Model CPAN distribution.

Report information
The Basics
Id: 14940
Status: resolved
Priority: 0/
Queue: Test-TAP-Model

People
Owner: Nobody in particular
Requestors: cpan.org [...] paulm.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.04
Fixed in: (no value)



Subject: requires => '>= 5.008' breaks YAML
Download (untitled) / with headers
text/plain 297b
I filed a bug against YAML for not correctly encoding a string starting with ">=": http://rt.cpan.org/NoAuth/Bug.html?id=14938 This affects software e.g. Debian's dh-make-perl that use the META.yml file. Module::Build docs suggest using requires => '5.8' which has the "5.8 or better" semantics.
Download (untitled) / with headers
text/plain 126b
Hmm, for some reason I didn't get notification about this bug. Anyway, it's resolved now, and I'm releasing 0.06. Thanks!
Download (untitled) / with headers
text/plain 195b
Okay, This was finally resolved with the big update to TTM. It's also got many new bugs which you can report if you find them (big new feature - consolidated models) ;-) THanks for the report


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.