Skip Menu |
 

This queue is for tickets about the Config-IniFiles CPAN distribution.

Report information
The Basics
Id: 1486
Status: resolved
Priority: 0/
Queue: Config-IniFiles

People
Owner: Nobody in particular
Requestors: ekirchst [...] us.ibm.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 2.29
Fixed in: 2.30



Subject: Problems with Config::IniFiles
Download (untitled) / with headers
text/plain 972b
I can't be sure this is not user error, but after downloading and running make test, I get the following error: "Can't use \x{} without 'use utf8' declaration at /tmp/Config-IniFiles-2.29/blib/lib/Config/IniFiles.pm line 518." This occurs for every test. I ran make install anyway and created the following script: #!/usr/bin/perl use Config::IniFiles; my $cfg = new Config::IniFiles( -file => "/tmp/perltmp/testfile.ini" ); print "We have parm " . $cfg->val( 'Section', 'Parameter' ) . "." if $cfg->val( 'Section', 'Parameter' ); This also failed with the following error: /^\x{FEFF}/: Can't use \x{} without 'use utf8' declaration at /usr/opt/perl5/lib/site_perl/5.6.0/Config/IniFiles.pm line 518. Compilation failed in require at initst.pl line 2. BEGIN failed--compilation aborted at initst.pl line 2. This also returned the following error: INFO: ===== Config-IniFiles-2.29 perl v5.6.0 built for aix AIX myhost 1 5 00009CDF4C00 AND RedHat Linux 7.2 ix86
From: jens-petter.salvesen [...] europay.no
Download (untitled) / with headers
text/plain 1.1k
[guest - Thu Aug 29 17:14:16 2002]: Show quoted text
> I can't be sure this is not user error, but after downloading and > running make test, I get the following error: "Can't use \x{} > without 'use utf8' declaration at /tmp/Config-IniFiles- > 2.29/blib/lib/Config/IniFiles.pm line 518." This occurs for every > test. I ran make install anyway and created the following script: > > > #!/usr/bin/perl > use Config::IniFiles; > > my $cfg = new Config::IniFiles( -file => "/tmp/perltmp/testfile.ini" > ); > print "We have parm " . $cfg->val( 'Section', 'Parameter' ) . "." > if $cfg->val( 'Section', 'Parameter' ); > > This also failed with the following error: > > /^\x{FEFF}/: Can't use \x{} without 'use utf8' declaration at > /usr/opt/perl5/lib/site_perl/5.6.0/Config/IniFiles.pm line 518. > Compilation failed in require at initst.pl line 2. > BEGIN failed--compilation aborted at initst.pl line 2. > This also returned the following error: > > INFO: > ===== > Config-IniFiles-2.29 > perl v5.6.0 built for aix > AIX myhost 1 5 00009CDF4C00 AND RedHat Linux 7.2 ix86
I had the same problem with perl 5.6.0 on a SuSE 7.2 Enterprise i686 server. I solved it by getting version 2.27.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.