This queue is for tickets about the IO-Prompt CPAN distribution.

Report information
The Basics
Id:
14453
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
pjf [...] perltraining.com.au
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
0.99.2
Fixed in:
(no value)



Subject: IO::Prompt wants "Want" but does not list it as a dependency.
G'day Damian, I've been looking at using IO::Prompt for a conference demonstration, and discovered a rather minor bug in the build process. IO::Prompt uses "Want" at line 186 of IO/Prompt.pm in the 0.99.2 distribution. However, this is not specified as a dependency in the Makefile.PL. As such, the extra module must be installed manually. Solution: Add "More" to PREREQ_PM in the Makefile.PL. Cheerio, Paul
From: cdolan@cpan.org
I would actually rate this a Critical bug because it prevents the clean installation of the package. -- Chris
Subject: Re: [rt.cpan.org #14453] IO::Prompt wants "Want" but does not list it as a dependency.
Date: Thu, 9 Feb 2006 13:24:55 +1100
To: bug-IO-Prompt@rt.cpan.org
From: Damian Conway <damian@conway.org>
Fixed in the next release. Thanks. Damian


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.