This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
14411
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
ANDK [...] cpan.org
Requestors:
adam [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
1.76
Fixed in:
(no value)



Subject: Convert to Module::Install and bundle Test-only package
After installing 5.005 to do some backwards-compatibility testing I had extreme problems with the age of the CPAN components. The first step after installing 5.005 is really to upgrade CPAN immediately, but to do that depends on Test::More and Test::Harness and some other test-time things that have to be installed first, which is subject to CPAN.pm's problems (the oooold version in 5.005) One solution to this could be to convert the CPAN.pm installation to use Module::Install, and take advantage of Module::Install's "include()" feature to include the current modern versions of Test::More and Test::Harness and so in in the CPAN.pm package itself, removing the need to upgrade anything other than CPAN.pm itself to get a sane install environment.
[ADAMK - Fri Sep 2 04:28:00 2005]:
Show quoted text
> After installing 5.005 to do some backwards-compatibility testing I > had extreme problems with the age of the CPAN components. > > The first step after installing 5.005 is really to upgrade CPAN > immediately, but to do that depends on Test::More and Test::Harness > and some other test-time things that have to be installed first, > which is subject to CPAN.pm's problems (the oooold version in > 5.005) > > One solution to this could be to convert the CPAN.pm installation to > use Module::Install, and take advantage of Module::Install's > "include()" feature to include the current modern versions of > Test::More and Test::Harness and so in in the CPAN.pm package > itself, removing the need to upgrade anything other than CPAN.pm > itself to get a sane install environment. >
One thing that would be very tricky to solve is the fact that CPAN 1.48 does not know that perl-5.8.7.tar.gz is a perl distro and it will happily try to download 5.8.7 for whatever it believes to need. To work around tis problem, you must sit in front of the CPAN shell and ^C as soon as it tries to unpack 5.8.7. The other thing seems to be that I forgot File::Temp in the prereqs and in the bundle. I just added them and believe this will make working with 5.00503 easy enough. I just tried it: -Install fresh 5.00503 -In the CPAN shell install Bundle::CPAN -Interrupt when it tries to download 5.8.7 with one single ^C but let it otherwise continue (many installs fail, includig CPAN, but be patient) -When back to the prompt, install File::Temp -install CPAN, this time it succeeds -leave the shell and start it again--seems to work nicely When I release 1.81 and File::emp is a normal prereq, this should work without the extra step for File::Temp.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.