Skip Menu |
 

This queue is for tickets about the AxKit CPAN distribution.

Report information
The Basics
Id: 14328
Status: new
Priority: 0/
Queue: AxKit

People
Owner: Nobody in particular
Requestors: rt.perl-axkit [...] mjo.tc
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Intermittent problem with MSIE 6.0 and CVS AxKit on RHEL 4
Download (untitled) / with headers
text/plain 693b
Runing AxKit from CVS (from 25.08.05) I sometimes see this error: [Fri Aug 26 16:12:22 2005] [error] [client a.b.c.d] [AxKit] [Error] Can't locate object method "parsed_uri" via package "Apache" at /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/Apache/AxKit/ConfigReader.pm line 347.\n The relevant line in ConfigReader is: elsif ($ua =~ /MSIE 6\.0/) { # Don't gzip https on MSIE 6.0 -> return if $r->parsed_uri->scheme =~ /https/i; } The problem seems intermittent, and seems hard to reproduce. Version info: perl: v5.8.5 built for i386-linux-thread-multi $Apache::VERSION 1.27 $Apache::Request::VERSION 1.33 $Apache::URI::VERSION 1.00 This is all on RHEL 4.
From: Martin Oldfield
Download (untitled) / with headers
text/plain 191b
Although I've no idea why, changing the test to if $r->uri =~ /^https:/ seems to solve the problem. If the two are thought to be equivalent, please could we have this form in AxKit 1.7 ?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.