Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the WWW-Mechanize CPAN distribution.

Report information
The Basics
Id: 14114
Status: rejected
Priority: 0/
Queue: WWW-Mechanize

People
Owner: Nobody in particular
Requestors: j.wetstein [...] ieee.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: line 1690 - no data returned?
Download (untitled) / with headers
text/plain 346b
When running webshots.pl (available from the web), I got the following: <input> outside <form> at [path to WWW-Mechanize.pm] line 1690 The code continues to run, but I then get a warning that "Couldn't find an image on http://community.webshots.com/photo/XXX/YYY" and it keeps going unsuccessfully. No die, only warn. I have 1.12 Any ideas?
Date: Thu, 11 Aug 2005 10:19:35 -0500
From: Mark Stosberg <mark [...] summersault.com>
To: Guest via RT <bug-WWW-Mechanize [...] rt.cpan.org>
Subject: Re: [cpan #14114] line 1690 - no data returned?
RT-Send-Cc:
Download (untitled) / with headers
text/plain 845b
On Thu, Aug 11, 2005 at 11:09:47AM -0400, Guest via RT wrote: Show quoted text
> > When running webshots.pl (available from the web), I got the following: > > <input> outside <form> at [path to WWW-Mechanize.pm] line 1690
This sounds like invalid HTML. Some people would prefer we were stricter and die in cases like this, others would prefer we work more like a "real world" browser and just cope with it. Show quoted text
> The code continues to run, but I then get a warning that "Couldn't > find an image on http://community.webshots.com/photo/XXX/YYY" and it > keeps going unsuccessfully. No die, only warn.
Finding an image looks unrelated. It would be great if you could look into this further and see if there is something strange/wrong with the webshots website, or if there is a specific bug in Mechanize. It could be correct to not find an image. Mark
Date: Thu, 11 Aug 2005 10:22:40 -0500
From: Andy Lester <andy [...] petdance.com>
To: Guest via RT <bug-WWW-Mechanize [...] rt.cpan.org>
CC: undisclosed-recipients: ;
Subject: Re: [cpan #14114] line 1690 - no data returned?
RT-Send-Cc:
Download (untitled) / with headers
text/plain 484b
On Thu, Aug 11, 2005 at 11:09:47AM -0400, Guest via RT (bug-WWW-Mechanize@rt.cpan.org) wrote: Show quoted text
> The code continues to run, but I then get a warning that "Couldn't > find an image on http://community.webshots.com/photo/XXX/YYY" and it > keeps going unsuccessfully. No die, only warn.
That's the nature of screen-scraping programs. Something that worked before may break when the site being scraped changes. -- Andy Lester => andy@petdance.com => www.petdance.com => AIM:petdance


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.