Skip Menu |
 

This queue is for tickets about the GD CPAN distribution.

Report information
The Basics
Id: 14042
Status: new
Priority: 0/
Queue: GD

People
Owner: Nobody in particular
Requestors: don [...] drakeconsult.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 2.27
Fixed in: 2.26



Subject: GD doesn't install GD/Image.pm
Download (untitled) / with headers
text/plain 3.2k
Subject says it all. With 2.27, I don't get a GD/Image.pm installed. I downgraded to 2.26 and it's fine. -Don [root@web01 GD-2.27]# perl -v perl -v This is perl, v5.8.5 built for x86_64-linux-thread-multi Copyright 1987-2004, Larry Wall Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit. Complete documentation for Perl, including FAQ lists, should be found on this system using `man perl' or `perldoc perl'. If you have access to the Internet, point your browser at http://www.perl.com/, the Perl Home Page. [root@web01 GD-2.27]# uname -a uname -a Linux web01.mobilemeridian.com 2.6.9-11.ELsmp #1 SMP Wed Jun 8 16:59:12 CDT 2005 x86_64 x86_64 x86_64 GNU/Linux [root@web01 GD-2.27]# perl Makefile.PL perl Makefile.PL NOTICE: This module requires libgd 2.0.25 or higher. it will NOT work with earlier versions. If you are getting compile or link errors, then please get and install a new version of libgd from www.boutell.com. Do NOT ask Lincoln for help until you try this. If you are using Math::Trig 1.01 or lower, it has a bug that causes a "prerequisite not found" warning to be issued. You may safely ignore this warning. Type perl Makefile.PL -h for command-line option summary Configuring for libgd version 2.0.33. Included Features: GD_JPEG GD_FREETYPE GD_PNG GD_GIF GD_UNCLOSEDPOLY GD_ANIMGIF GD_FTCIRCLE VERSION_33 GD library used from: /usr/local If you experience compile problems, please check the @INC, @LIBPATH and @LIBS arrays defined in Makefile.PL and manually adjust, if necessary. Writing Makefile for GD [root@web01 GD-2.27]# make make gcc -c -I/usr/local/include -D_REENTRANT -D_GNU_SOURCE -DDEBUGGING -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -g -pipe -m64 -DVERSION=\"2.27\" -DXS_VERSION=\"2.27\" -fPIC "-I/usr/lib64/perl5/5.8.5/x86_64-linux-thread-multi/CORE" -DHAVE_JPEG -DHAVE_FT -DHAVE_GIF -DHAVE_PNG -DHAVE_ANIMGIF -DVERSION_33 -DHAVE_UNCLOSEDPOLY -DHAVE_FTCIRCLE GD.c Running Mkbootstrap for GD () chmod 644 GD.bs rm -f blib/arch/auto/GD/GD.so gcc -shared GD.o -o blib/arch/auto/GD/GD.so -L/usr/local/lib -L/usr/local/lib -L/usr/local/lib -L/usr/local/lib64 -L/usr/local/lib64 -L/usr/local/lib64 -ljpeg -lfreetype -lpng12 -lz -lm -lgd chmod 755 blib/arch/auto/GD/GD.so cp GD.bs blib/arch/auto/GD/GD.bs chmod 644 blib/arch/auto/GD/GD.bs cp bdf_scripts/bdf2gdfont.pl blib/script/bdf2gdfont.pl /usr/bin/perl "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/bdf2gdfont.pl Manifying blib/man1/bdf2gdfont.pl.1 Manifying blib/man3/GD::Polyline.3pm Manifying blib/man3/GD::Simple.3pm Manifying blib/man3/GD.3pm [root@web01 GD-2.27]# make install make install Installing /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/auto/GD/GD.so Files found in blib/arch: installing files in blib/lib into architecture dependent library tree Installing /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/GD.pm Writing /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/auto/GD/.packlist Appending installation info to /usr/lib64/perl5/5.8.5/x86_64-linux-thread-multi/perllocal.pod
From: tthome [...] cox.net
Download (untitled) / with headers
text/plain 167b
[guest - Sun Aug 7 10:08:54 2005]: Seeing same thing here. Fedora Core 3, 2.6.12, x86 (32bit), GD2.0.33, perl 5.8.5 backed off to v2.25 and things are back up. Tim
From: lion [...] apocalypse.org
Download (untitled) / with headers
text/plain 569b
[guest - Sun Aug 7 14:39:34 2005]: Diddo on Fedora FC 4. Also, GD/Polygon.pm is *not* install as well. Around line 196 in Makefile.PL should look like to fix things: 'PM' => { 'GD.pm' => '$(INST_LIBDIR)/GD.pm', 'GD/Polyline.pm' => '$(INST_LIBDIR)/GD/Polyline.pm', 'GD/Polygon.pm' => '$(INST_LIBDIR)/GD/Polygon.pm', 'GD/Simple.pm' => '$(INST_LIBDIR)/GD/Simple.pm', 'GD/Image.pm' => '$(INST_LIBDIR)/GD/Image.pm', 'qd.pl' => '$(INST_LIBDIR)/qd.pl'},


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.