Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI CPAN distribution.

Report information
The Basics
Id: 13903
Status: resolved
Priority: 0/
Queue: CGI

People
Owner: Nobody in particular
Requestors: thomas.lauer [...] virgin.net
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: bug in start_form
Download (untitled) / with headers
text/plain 375b
CGI.pm 3.10, Perl 5.8.7, Win2K-SP4. Line 1802 in CGI.pm has a typo (two indeed), I think: if (defined($param[0]) && substr($param[0],0,1) eq '-') { What we want is this: if (defined($p[0]) && substr($p[0],0,1) eq '-') { At least, with this change in place the generated HTML form is valid XHTML whereas before there are two enctype attributes inside the form tag.
Download (untitled) / with headers
text/plain 607b
On Thu Jul 28 04:51:06 2005, guest wrote: Show quoted text
> CGI.pm 3.10, Perl 5.8.7, Win2K-SP4. > > Line 1802 in CGI.pm has a typo (two indeed), I think: > if (defined($param[0]) && substr($param[0],0,1) eq '-') { > > What we want is this: > if (defined($p[0]) && substr($p[0],0,1) eq '-') { > > At least, with this change in place the generated HTML form is valid > XHTML whereas before there are two enctype attributes inside the form tag.
Thanks for the report. In reviewing CGI.pm 3.43, I'm just confirming that your fix was integrated some time ago, so this bug report can be considered resolved. Mark


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.