Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Time-HiRes CPAN distribution.

Report information
The Basics
Id:
13768
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
LGODDARD [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
1.72
Fixed in:
(no value)



Subject: perl -MCPAN install fails
perl -MCPAN -e shell
Show quoted text
>install Time::HiRes
CPAN.pm: Going to build J/JH/JHI/Time-HiRes-1.72.tar.gz Configuring Time::HiRes... Looking for gettimeofday()... found. Looking for setitimer()... found. Looking for getitimer()... found. You have interval timers (both setitimer and getitimer). Looking for ualarm()... found. Looking for usleep()... found. Looking for nanosleep()... found. You can mix subsecond sleeps with signals, if you want to. (It's still not portable, though.) Checking if your kit is complete... Looks good Writing Makefile for Time::HiRes Now you may issue 'make'. Do not forget also 'make test'. NOTE: if you get an error like this (the line number may vary): Makefile:91: *** missing separator then set the environment variable LC_ALL to "C" and retry from scratch (re-run perl "Makefile.PL"). Makefile:91: *** missing separator. Stop. /usr/bin/make -- NOT OK Running make test Can't test without successful make Running make install make had returned bad status, install seems impossible [root@dave11 root]# uname -o -s -v -p -i Linux #1 Tue May 17 18:01:37 EDT 2005 i686 i386 GNU/Linux [root@dave11 root]# perl -v This is perl, v5.8.0 built for i386-linux-thread-multi
Forgot to add that I set the environment variable as requested.
[LGODDARD - Tue Jul 19 03:52:32 2005]:
Show quoted text
> Forgot to add that I set the environment variable as requested.
You did export LC_ALL=C *before* running perl -MCPAN -e shell right?
From: Jon Daniels
Hi, Anyone get a workaround for this. I have set and exported the env var and rerun the install both maually and via CPAN. Same problem persists. Any further ideas? Cheers, Jon On Wed Jul 20 03:04:03 2005, JHI wrote:
Show quoted text
> [LGODDARD - Tue Jul 19 03:52:32 2005]: >
> > Forgot to add that I set the environment variable as requested.
> > You did > > export LC_ALL=C > > *before* running > > perl -MCPAN -e shell > > right?
Never mind - Sorry! The env var was not exported properly, and it now works, but I _did_ find that it only works via CPAN, not manually. Jon On Wed Feb 15 07:35:51 2006, guest wrote:
Show quoted text
> Hi, > > Anyone get a workaround for this. I have set and exported the env var > and rerun the install both maually and via CPAN. Same problem persists. > > Any further ideas? > > Cheers, > Jon > > > > On Wed Jul 20 03:04:03 2005, JHI wrote:
> > [LGODDARD - Tue Jul 19 03:52:32 2005]: > >
> > > Forgot to add that I set the environment variable as requested.
> > > > You did > > > > export LC_ALL=C > > > > *before* running > > > > perl -MCPAN -e shell > > > > right?
> >


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.