Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the PPI CPAN distribution.

Report information
The Basics
Id: 13626
Status: resolved
Worked: 10 min
Priority: 0/
Queue: PPI

People
Owner: adamk [...] cpan.org
Requestors: johanl [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: (no value)
Fixed in: (no value)



Subject: cvs: require of PPI::XS dies
Download (untitled) / with headers
text/plain 428b
This is for the 1.0 cvs version: I guess the XS_DISABLE is set in all .t files, because all tests pass. But when using PPI outside the tests, the module doesn't load at all. PPI.pm, line 27 should use parens to fix the precedence between and/or. # If it is installed, load in PPI::XS unless ( $PPI::XS_DISABLE ) { eval { require PPI::XS }; $@ and ($@ =~ /^Can\'t locate PPI/ or die $@); # Only ignore if not installed }


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.