Skip Menu |
 
rt.cpan.org will be shut down on March 1st, 2021.

This queue is for tickets about the Encode CPAN distribution.

Report information
The Basics
Id: 133850
Status: resolved
Priority: 0/
Queue: Encode

People
Owner: Nobody in particular
Requestors: davem [...] iabyn.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Encode requires Test::More 0.81_01 - this warns
Date: Tue, 1 Dec 2020 15:57:14 +0000
To: bug-Encode [...] rt.cpan.org
From: Dave Mitchell <davem [...] iabyn.com>
Download (untitled) / with headers
text/plain 1024b
Encode (certainly the version 3.07 bundled with bleadperl) has this in Makefile.PL: TEST_REQUIRES => { 'Test::More' => '0.81_01', }, When built as part of blead, this causes the following noise on stderr: Argument "0.81_01" isn't numeric in numeric gt (>) at /home/davem/perl5/git/bleed/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm line 618. As a general goal of mine is that building bleadperl should produce nothing on stderr, it would be nice if this warning went away. I assume it's due to the development version of Test::More specified, i.e. the _01. AFAIKT, there's no real need for such a precise requirement; a look at perl releases shows the following versions of Test::More were bundled: 5.8.0 0.45 5.8.9 0.80 5.9.0 0.47 5.9.5 0.70 5.10.0 0.72 5.10.1 0.92 5.11.0 0.92 5.12.0 0.94 So I guess just requiring 'Test::More' => '0.92' would suffice. -- Justice is when you get what you deserve. Law is when you get what you pay for.
Download (untitled) / with headers
text/plain 1.1k
Thank you. fixed in https://github.com/dankogai/p5-encode/commit/3bf67975b23e13710d5dc539d6539b7449dada17 I will VERSION++ right after this. Dan the Maintainer Thereof On Tue Dec 01 12:24:52 2020, davem@iabyn.com wrote: Show quoted text
> Encode (certainly the version 3.07 bundled with bleadperl) has this in > Makefile.PL: > > TEST_REQUIRES => { > 'Test::More' => '0.81_01', > }, > > When built as part of blead, this causes the following noise on > stderr: > > Argument "0.81_01" isn't numeric in numeric gt (>) at > /home/davem/perl5/git/bleed/cpan/ExtUtils- > MakeMaker/lib/ExtUtils/MakeMaker.pm line 618. > > As a general goal of mine is that building bleadperl should produce > nothing on stderr, it would be nice if this warning went away. I > assume > it's due to the development version of Test::More specified, i.e. the > _01. > > AFAIKT, there's no real need for such a precise requirement; a look at > perl releases shows the following versions of Test::More were bundled: > > 5.8.0 0.45 > 5.8.9 0.80 > > 5.9.0 0.47 > 5.9.5 0.70 > > 5.10.0 0.72 > 5.10.1 0.92 > > 5.11.0 0.92 > > 5.12.0 0.94 > > So I guess just requiring 'Test::More' => '0.92' would suffice.
Download (untitled) / with headers
text/plain 319b
I've created two pull requests that I believe are a better solution to this problem. https://github.com/Perl-Toolchain-Gang/ExtUtils-MakeMaker/pull/382 https://github.com/Perl-Toolchain-Gang/CPAN-Meta-Requirements/pull/34 If they are merged, they should allow EUMM to handle prereqs like this without warning in core.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.