This queue is for tickets about the XS-libpanda CPAN distribution.

Report information
The Basics
Id:
133646
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
twata_1 [...] yahoo.co.jp
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
  • 1.4.10
  • 1.4.11
Fixed in:
(no value)



Subject: t/log/formatter.t seems to cause an Windows 8.1 freeze.
Hello, When I execute "cpan XS::libpanda" on command prompt under Windows 8.1, It seems to me that t/log/formatter.t cause an OS freeze. The disk access lamp stays on all the time. The key input was not accepted. Mouse operation is no longer accepted. [Environment] Windows 8.1 64 bit Strawberry Perl 5.26.1 64 bit Thank you, -- twata
Вск Ноя 01 06:08:35 2020, twata_1@yahoo.co.jp писал:
Show quoted text
> Hello, > > When I execute "cpan XS::libpanda" on command prompt under Windows > 8.1, It seems to me that t/log/formatter.t cause an OS freeze. > The disk access lamp stays on all the time. > The key input was not accepted. > Mouse operation is no longer accepted. > > [Environment] > Windows 8.1 64 bit > Strawberry Perl 5.26.1 64 bit > > > Thank you, > -- > twata
Hi! Tried win8.1 x64 and all strawberries 5.26 to 5.32 and all is working fine. win10 also everything's fine. Could you please check with strawberry 5.32 latest on the same OS to determine if it's something special with your perl instance or with your win8.1 instance. strawberry 5.26's mingw version is old and has various bugs
Hi, Thank you for your reply. I have checked with Strawberry Perl 5.32.0 on the same OS. I was able to install it without any problems. Thank you, -- twata On 2020-11月-18 水 15:46:51, SYBER wrote:
Show quoted text
> Вск Ноя 01 06:08:35 2020, twata_1@yahoo.co.jp писал:
> > Hello, > > > > When I execute "cpan XS::libpanda" on command prompt under Windows > > 8.1, It seems to me that t/log/formatter.t cause an OS freeze. > > The disk access lamp stays on all the time. > > The key input was not accepted. > > Mouse operation is no longer accepted. > > > > [Environment] > > Windows 8.1 64 bit > > Strawberry Perl 5.26.1 64 bit > > > > > > Thank you, > > -- > > twata
> > Hi! > Tried win8.1 x64 and all strawberries 5.26 to 5.32 and all is working > fine. > win10 also everything's fine. > > Could you please check with strawberry 5.32 latest on the same OS to > determine if it's something special with your perl instance or with > your win8.1 instance. > > strawberry 5.26's mingw version is old and has various bugs
Thanks for testing! Could you possibly check it with fresh-installed 5.26.1? And if it’s not working then latest 5.26.3 ?
I installed 5.26.1 again. But The situation was the same. I installed 5.26.3. But The situation was the same. For my environment about 5.26.3, Please see the following report when I installed XS::Install. http://www.cpantesters.org/cpan/report/fbdb21b8-6ef6-1014-9b26-cf3376a13fd6 On 2020-11月-21 土 09:38:05, SYBER wrote:
Show quoted text
> Thanks for testing! Could you possibly check it with fresh-installed > 5.26.1? And if it’s not working then latest 5.26.3 ?


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.