Skip Menu |
 

This queue is for tickets about the Net-Google-Code CPAN distribution.

Report information
The Basics
Id: 132902
Status: open
Priority: 0/
Queue: Net-Google-Code

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.19
Fixed in: (no value)



Subject: Test suite started to fail (because of mocked $LWP::UserAgent::VERSION ?)
Download (untitled) / with headers
text/plain 460b
The test suite started to fail --- a sample report: http://www.cpantesters.org/cpan/report/6c107468-b58c-11ea-8238-d2771f24ea8f This seems to happen since WWW::Mechanize, which requires a newer LWP::UserAgent version than before. And possibly these two lines: * https://metacpan.org/source/SUNNAVY/Net-Google-Code-0.19/t/google_api/01-issue.t#L8 * https://metacpan.org/source/SUNNAVY/Net-Google-Code-0.19/t/google_api/02-comment.t#L7 are now causing problems.
Subject: Re: [rt.cpan.org #132902] Test suite started to fail (because of mocked $LWP::UserAgent::VERSION ?)
Date: Sun, 28 Jun 2020 15:56:39 -0700
To: bug-Net-Google-Code [...] rt.cpan.org
From: Jesse Vincent <jesse [...] fsck.com>
At this point, the service has been abandoned by google and this code is of only historical interest. Show quoted text
> On Jun 28, 2020, at 1:05 PM, Slaven_Rezic via RT <bug-Net-Google-Code@rt.cpan.org> wrote: > > Sun Jun 28 16:05:39 2020: Request 132902 was acted upon. > Transaction: Ticket created by SREZIC > Queue: Net-Google-Code > Subject: Test suite started to fail (because of mocked $LWP::UserAgent::VERSION > ?) > Broken in: 0.19 > Severity: (no value) > Owner: Nobody > Requestors: SREZIC@cpan.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=132902 > > > > The test suite started to fail --- a sample report: http://www.cpantesters.org/cpan/report/6c107468-b58c-11ea-8238-d2771f24ea8f > This seems to happen since WWW::Mechanize, which requires a newer LWP::UserAgent version than before. And possibly these two lines: > * https://metacpan.org/source/SUNNAVY/Net-Google-Code-0.19/t/google_api/01-issue.t#L8 > * https://metacpan.org/source/SUNNAVY/Net-Google-Code-0.19/t/google_api/02-comment.t#L7 > are now causing problems. >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.