Skip Menu |
 

This queue is for tickets about the Device-Chip-BNO055 CPAN distribution.

Report information
The Basics
Id: 132490
Status: new
Priority: 0/
Queue: Device-Chip-BNO055

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.01
Fixed in: (no value)



Subject: Requires newer versions of Future::AsyncAwait?
Download (untitled) / with headers
text/plain 1.2k
The test suite fails on some of my smokers: ... # Failed test 'use Device::Chip::BNO055;' # at t/00use.t line 8. # Tried to use 'Device::Chip::BNO055'. # Error: Expected async to be followed by sub at /home/cpansand/.cpan/build/2020050311/Device-Chip-BNO055-0.01-0/blib/lib/Device/Chip/BNO055.pm line 143. # Compilation failed in require at t/00use.t line 8. # BEGIN failed--compilation aborted at t/00use.t line 8. # Looks like you failed 1 test of 1. t/00use.t ....... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests ... (etc) ... Statistical analysis suggests that it fails with Future::AwaitAsync 0.35 and 0.37, possibly also with older versions: **************************************************************** Regression 'mod:Future::AsyncAwait' **************************************************************** Name Theta StdErr T-stat [0='const'] 0.0000 0.0000 0.35 [1='eq_0.35'] -0.0000 0.0000 -0.87 [2='eq_0.37'] 0.0000 0.0000 1.00 [3='eq_0.39'] 1.0000 0.0000 2950546803852176.50 [4='eq_0.40'] 1.0000 0.0000 3139738037060100.00 R^2= 1.000, N= 43, K= 5 ****************************************************************


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.