Skip Menu |
 

This queue is for tickets about the Encode CPAN distribution.

Report information
The Basics
Id: 132377
Status: resolved
Priority: 0/
Queue: Encode

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc: ANDK [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: 3.05
Fixed in: (no value)



CC: ANDK [...] cpan.org
Subject: Increase $VERSION of encoding.pm?
Download (untitled) / with headers
text/plain 801b
On some of my perl systems upgrading Encode with CPAN.pm requires manual intervention: ... allow_installing_module_downgrades: DANKOGAI/Encode-3.05.tar.gz (called for Encode) contains downgrading module(s) (e.g. 'encoding.pm' would downgrade installed '2.6_01' to '2.22'). Do you want to allow installing it? [yes] ... Looking at Module::CoreList data, perl versions between 5.10.1 and 5.19.0 shipped an encoding.pm with a higher version than nowadays (2.6_01 == 2.601 > 2.22). This was unnoticed until recent CPAN.pm versions started to complain about possible module downgrades. Probably the best is to increase the version of encoding.pm to at least 2.61. (And while at this, it seems that $VERSION of encoding.pm is built using a RCS/CVS styled identifier, which is possibly obsolete nowadays)
Download (untitled) / with headers
text/plain 1.1k
Thank you. Bumped its version to 3.00 accordingly to your suggestion. https://github.com/dankogai/p5-encode/commit/c9e52a8b9d2c763508d0c9cddbf95a5aa20cebf8#diff-5fc1dc9c881c7f7a6cdfad7c333d155b It is an irony to update a deprecated module to keep it deprecated. Dan the Maintainer Thereof On Sun Apr 19 05:46:59 2020, SREZIC wrote: Show quoted text
> On some of my perl systems upgrading Encode with CPAN.pm requires > manual intervention: > > ... > allow_installing_module_downgrades: DANKOGAI/Encode-3.05.tar.gz > (called for Encode) contains downgrading module(s) (e.g. 'encoding.pm' > would downgrade installed '2.6_01' to '2.22'). Do you want to allow > installing it? [yes] > ... > > Looking at Module::CoreList data, perl versions between 5.10.1 and > 5.19.0 shipped an encoding.pm with a higher version than nowadays > (2.6_01 == 2.601 > 2.22). This was unnoticed until recent CPAN.pm > versions started to complain about possible module downgrades. > Probably the best is to increase the version of encoding.pm to at > least 2.61. (And while at this, it seems that $VERSION of encoding.pm > is built using a RCS/CVS styled identifier, which is possibly obsolete > nowadays)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.