Skip Menu |
 
Update: The rt.cpan.org bug tracker service is no longer shutting down.

This queue is for tickets about the Config-Any CPAN distribution.

Report information
The Basics
Id: 132342
Status: open
Priority: 0/
Queue: Config-Any

People
Owner: Nobody in particular
Requestors: ovid [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 0.31
  • 0.32
Fixed in: (no value)



Subject: Config::Any::General requires a non-existent Config::General
Download (untitled) / with headers
text/plain 737b
In https://metacpan.org/source/HAARG/Config-Any-0.32/lib/Config/Any/General.pm, we see the following line: sub requires_all_of { [ 'Config::General' => '2.47' ] } That version does not appear to exist. It's referenced in the Changes file (https://metacpan.org/changes/distribution/Config-General), but the next version, 2.48, mentions an issue with the 2.47 upload. This caused an issue with our Carton install today because for me (others didn't have this issue), Config::Any kept trying to force an install of Config::General 2.47 (and not a newer version). I had to force an install of a new version to work around this. The specification of 2.47 for Config::General first appeared in Config::Any::General in 0.30. Best, Ovid
Download (untitled) / with headers
text/plain 1.3k
On Tue Apr 14 06:40:40 2020, OVID wrote: Show quoted text
> In https://metacpan.org/source/HAARG/Config-Any- > 0.32/lib/Config/Any/General.pm, we see the following line: > > sub requires_all_of { [ 'Config::General' => '2.47' ] } > > That version does not appear to exist. It's referenced in the Changes > file (https://metacpan.org/changes/distribution/Config-General), but > the next version, 2.48, mentions an issue with the 2.47 upload. > > This caused an issue with our Carton install today because for me > (others didn't have this issue), Config::Any kept trying to force an > install of Config::General 2.47 (and not a newer version). I had to > force an install of a new version to work around this. > > The specification of 2.47 for Config::General first appeared in > Config::Any::General in 0.30. > > Best, > Ovid
This seems like a problem with your Carton setup. Specifying a version minimum, even if that specific version doesn't exist, should not cause any problems with normal install tools. Additionally, 2.47 does exist (https://metacpan.org/release/TLINDEN/Config-General-2.47) and can be found by cpanm. 2.47 does appear to be a broken release, but that's because of a compile time error and thus a test failure, not a failure to find the release. I could bump the prerequisite to 2.48, but I believe your issue lies elsewhere.
On Tue Apr 14 08:27:58 2020, haarg wrote: Show quoted text
> This seems like a problem with your Carton setup. Specifying a > version minimum, even if that specific version doesn't exist, should > not cause any problems with normal install tools.
I was suspecting that, but wasn't sure. Show quoted text
> Additionally, 2.47 > does exist (https://metacpan.org/release/TLINDEN/Config-General-2.47) > and can be found by cpanm.
I wonder if that should be considered a bug in metacpan. I assumed it somehow wasn't indexed because when I select the "Jump to version" dropdown on the Config::General pages, 2.47 doesn't appear. Hence, my assuming it wasn't there! Show quoted text
> 2.47 does appear to be a broken release, > but that's because of a compile time error and thus a test failure, > not a failure to find the release. > > I could bump the prerequisite to 2.48, but I believe your issue lies > elsewhere.
Again, I suspect you're right as other devs for my client didn't report this issue. But it still might be nice to get a bump as it's pointing to a broken release. In any event, thank you for your time, Graham! Best, Ovid


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.