This queue is for tickets about the XS-Parse-Sublike CPAN distribution.

Report information
The Basics
Id:
132248
Status:
new
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
leonerd-cpan [...] leonerd.org.uk
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
0.05
Fixed in:
(no value)



Subject: Consider supporting sub signatures back as far as 5.20
Currently X:P:S can only implement parse_subsignature() back as far as 5.26 because that is the version in which the specific OPs were implemented to handle it. Prior versions of perl back as far as 5.20 did implement signatures but did so by constructing a full optree from existing core ops to create the behaviour. It would not be technically difficult to do the same in X:P:S; either by generating the same optrees (thus they would deparse the same), or just providing custom XOPs that implement the logic instead. The tradeoff here is the extra effort to actually write and maintain it, only to support these older versions of perl. I currently consider it almost not worth it; except that it *might* make sense to be able to support back as far as 5.24 because that is when non-experimental postfix-deref arrived; and seems to be a nice horizon on perl versions to get a good set of features. Will take suggestions either way... -- Paul Evans


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.