Skip Menu |
 

This queue is for tickets about the CGI-Simple CPAN distribution.

Report information
The Basics
Id: 131573
Status: new
Priority: 0/
Queue: CGI-Simple

People
Owner: Nobody in particular
Requestors: guido.selva [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: File uploads not working when filename contains non-ASCII characters?
Date: Sun, 26 Jan 2020 19:16:53 +0100
To: bug-CGI-Simple [...] rt.cpan.org
From: Guido Selva <guido.selva [...] gmail.com>
Download (untitled) / with headers
text/plain 900b
Hi, I am migrating a web site from CGI.pm to CGI::Simple, but I cannot make work the file upload feature when the filename being uploaded contains non-ASCII characters. Everything works fine with filenames containing only ASCII characters. For example if I create a text file called "café.txt" and upload it, I can get its filename with $q->param('upload_field'), but I cannot get its properties with $q->upload_info(), nor copy it with $CGI->upload($filename). In the first case I get an undefined return value, in the second case an error. It seems like the temporary file is not found. I tried playing with $CGI::Simple::PARAM_UTF8, and tried encoding/decoding the filename with Encode::decode('UTF-8', $filename), but nothing works, I cannot get the file's properties nor copy it. Should CGI:Simple upload feature work with filenames containing non-ASCII characters? Thanks Guido


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.