Skip Menu |
 

This queue is for tickets about the XML-LibXSLT CPAN distribution.

Report information
The Basics
Id: 131457
Status: open
Priority: 0/
Queue: XML-LibXSLT

People
Owner: Nobody in particular
Requestors: jplesnik [...] redhat.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Tests failes with XML-LibXML-2.0202
Date: Tue, 14 Jan 2020 11:20:48 +0100
To: bug-XML-LibXSLT [...] rt.cpan.org
From: Jitka Plesnikova <jplesnik [...] redhat.com>
Download (untitled) / with headers
text/plain 742b
The test t/06entities.t failed with XML-LibXML-2.0202. #   Failed test '$tostring matches entity.' #   at t/06entities.t line 41. #                   '<?xml version="1.0"?> # <out>foobar</out> # ' #     doesn't match '(?^i:foo(?:.|&#xF6;)bar)' #   Failed test '$content matches entity.' #   at t/06entities.t line 49. #                   '<?xml version="1.0"?> # <out>foobar</out> # ' #     doesn't match '(?^i:foo(?:&#xF6;|\xC3\xB6)bar)' # Looks like you failed 2 tests of 2. t/06entities.t ............ Dubious, test returned 2 (wstat 512, 0x200) Failed 2/2 subtests It probably happened, because loading external DTDs or external entities is disabled by default in XML-LibXML-2.0202.
Download (untitled) / with headers
text/plain 898b
On Tue Jan 14 05:22:16 2020, jplesnik wrote: Show quoted text
> The test t/06entities.t failed with XML-LibXML-2.0202. > > #   Failed test '$tostring matches entity.' > #   at t/06entities.t line 41. > #                   '<?xml version="1.0"?> > # <out>foobar</out> > # ' > #     doesn't match '(?^i:foo(?:.|&#xF6;)bar)' > #   Failed test '$content matches entity.' > #   at t/06entities.t line 49. > #                   '<?xml version="1.0"?> > # <out>foobar</out> > # ' > #     doesn't match '(?^i:foo(?:&#xF6;|\xC3\xB6)bar)' > # Looks like you failed 2 tests of 2. > t/06entities.t ............ > Dubious, test returned 2 (wstat 512, 0x200) > Failed 2/2 subtests > > It probably happened, because loading external DTDs or external entities > is disabled by default in XML-LibXML-2.0202.
Hi, this should be fixed in X-LibXSLT 1.98. Can we close this bug?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.