Skip Menu |
 

This queue is for tickets about the Devel-Declare CPAN distribution.

Report information
The Basics
Id: 131212
Status: rejected
Priority: 0/
Queue: Devel-Declare

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.006_020
Fixed in: (no value)



Subject: Compilation error with perl 5.31.6
Download (untitled) / with headers
text/plain 2.2k
The devel version does not compile with perl 5.31.6: ... cc -c -I/usr/perl5.31.6p/lib/site_perl/5.31.6/amd64-freebsd/B/Hooks/OP/Check/Install -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2 -O2 -pipe -DVERSION=\"0.006_020\" -DXS_VERSION=\"0.006_020\" -DPIC -fPIC "-I/usr/perl5.31.6p/lib/5.31.6/amd64-freebsd/CORE" Declare.c In file included from Declare.xs:7: ./stolen_chunk_of_toke.c:980:6: error: too many arguments provided to function-like macro invocation ( isALNUM_lazy_if_safe(s+1,send,UTF) ^ ./stolen_chunk_of_toke.c:202:45: note: expanded from macro 'isALNUM_lazy_if_safe' ((! UTF || p > e) ? isALNUM_lazy_if(p,UTF) : 0) ^ /usr/perl5.31.6p/lib/5.31.6/amd64-freebsd/CORE/utf8.h:709:26: note: expanded from macro 'isALNUM_lazy_if' "isWORDCHAR_lazy_if_safe", \ ^ /usr/perl5.31.6p/lib/5.31.6/amd64-freebsd/CORE/embed.h:36:9: note: macro '_is_utf8_FOO' defined here #define _is_utf8_FOO(a,b,c) Perl__is_utf8_FOO(aTHX_ a,b,c) ^ In file included from Declare.xs:7: ./stolen_chunk_of_toke.c:980:6: error: use of undeclared identifier '_is_utf8_FOO' ( isALNUM_lazy_if_safe(s+1,send,UTF) ^ ./stolen_chunk_of_toke.c:202:45: note: expanded from macro 'isALNUM_lazy_if_safe' ((! UTF || p > e) ? isALNUM_lazy_if(p,UTF) : 0) ^ /usr/perl5.31.6p/lib/5.31.6/amd64-freebsd/CORE/utf8.h:708:13: note: expanded from macro 'isALNUM_lazy_if' _is_utf8_FOO(_CC_IDFIRST, (const U8 *) p, "isALNUM_lazy_if", \ ^ In file included from Declare.xs:7: ./stolen_chunk_of_toke.c:1014:27: warning: '&&' within '||' [-Wlogical-op-parentheses] && isIDFIRST_utf8_safe(e, send) ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ./stolen_chunk_of_toke.c:1014:27: note: place parentheses around the '&&' expression to silence this warning && isIDFIRST_utf8_safe(e, send) ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 1 warning and 2 errors generated. *** Error code 1 ...
Download (untitled) / with headers
text/plain 189b
On 2019-12-22 07:56:55, SREZIC wrote: Show quoted text
> The devel version does not compile with perl 5.31.6:
Yes, blead didn't get the necessary fixes for this distribution until 5.31.7, which is now out.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.