Skip Menu |
 

This queue is for tickets about the Scalar-List-Utils CPAN distribution.

Report information
The Basics
Id: 130935
Status: open
Priority: 0/
Queue: Scalar-List-Utils

People
Owner: Nobody in particular
Requestors: dpetersen112 [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Install problem
Date: Thu, 7 Nov 2019 10:55:01 -0600
To: bug-Scalar-List-Utils [...] rt.cpan.org
From: Don Petersen <dpetersen112 [...] gmail.com>
Download (untitled) / with headers
text/plain 4.1k
When I tried installing Dancer2, I got the errors listed below. platform: HP Win10 Home, 64 bit, V 1809, build 17763.805 This is perl 5, version 16, subversion 3 (v5.16.3) built for MSWin32-x64-multi-thread reports PEVANS/Scalar-List-Utils-1.53.tar.gz listed many +PASS, several -FAIL, and a few UNKNOWN The abridged output from Show quoted text
cpan> install Dancer2
. . . CPAN.pm: Building C/CR/CROMEDOME/Dancer2-0.208001.tar.gz Checking if your kit is complete... Looks good Warning: prerequisite App::Cmd::Setup 0 not found. Warning: prerequisite Config::Any 0 not found. Warning: prerequisite Exporter::Tiny 0 not found. Warning: prerequisite File::Share 0 not found. Warning: prerequisite Hash::Merge::Simple 0 not found. Warning: prerequisite Hash::MultiValue 0 not found. Warning: prerequisite Import::Into 0 not found. Warning: prerequisite JSON::MaybeXS 0 not found. Warning: prerequisite List::Util 1.29 not found. We have 1.27. Warning: prerequisite Moo 2.000000 not found. We have 1.000008. Warning: prerequisite Plack 1.0040 not found. Warning: prerequisite Plack::Middleware::FixMissingBodyInRedirect 0 not found. Warning: prerequisite Plack::Middleware::RemoveRedundantBody 0 not found. Warning: prerequisite Return::MultiLevel 0 not found. Warning: prerequisite Role::Tiny 2.000000 not found. We have 1.002005. Warning: prerequisite Safe::Isa 0 not found. Warning: prerequisite Test::CPAN::Meta 0 not found. Warning: prerequisite Test::EOL 0 not found. Warning: prerequisite Type::Tiny 1.000006 not found. Warning: prerequisite Types::Standard 0 not found. Generating a dmake-style Makefile Writing Makefile for Dancer2 Writing MYMETA.yml and MYMETA.json Show quoted text
---- Unsatisfied dependencies detected during ---- ---- CROMEDOME/Dancer2-0.208001.tar.gz ---- . . . Running make test C:\"strawberry\perl\bin\perl.exe" -MExtUtils::Command::MM -e cp_nonempty -- Util.bs blib\arch\auto\List\Util\Util.bs 644 C:\"strawberry\perl\bin\perl.exe" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib\lib', 'blib\arch')" t/*.t t/00version.t ......... ok t/any-all.t ........... ok t/blessed.t ........... ok t/dualvar.t ........... ok t/exotic_names.t ...... ok t/first.t ............. ok t/getmagic-once.t ..... ok t/head-tail.t ......... ok t/isvstring.t ......... ok t/lln.t ............... ok t/max.t ............... ok t/maxstr.t ............ ok t/min.t ............... ok t/minstr.t ............ ok t/openhan.t ........... ok t/pair.t .............. ok t/product.t ........... ok t/prototype.t ......... ok t/readonly.t .......... ok t/reduce.t ............ ok t/refaddr.t ........... ok t/reftype.t ........... ok t/rt-96343.t .......... ok t/scalarutil-proto.t .. ok t/shuffle.t ........... ok t/stack-corruption.t .. ok t/subname.t ........... ok t/sum.t ............... ok t/sum0.t .............. ok t/tainted.t ........... ok t/uniq.t .............. 1/33 Argument "1.#INF" isn't numeric in subroutine entry at t/uniq.t line 115. Argument "-1.#IND" isn't numeric in subroutine entry at t/uniq.t line 115. # Failed test 'uniqnum preserves uniqness of full integer range (stringified)' # at t/uniq.t line 115. # Structures begin differing at: # $got->[4] = '9223372036854775807' # $expected->[4] = '-1.#IND' # Looks like you failed 1 test of 33. t/uniq.t .............. Dubious, test returned 1 (wstat 256, 0x100) Failed 1/33 subtests t/weak.t .............. ok Test Summary Report ------------------- t/uniq.t (Wstat: 256 Tests: 33 Failed: 1) Failed test: 18 Non-zero exit status: 1 Files=32, Tests=2091, 11 wallclock secs ( 0.55 usr + 0.19 sys = 0.73 CPU) Result: FAIL Failed 1/32 test programs. 1/2091 subtests failed. dmake.exe: Error code 255, while making 'test_dynamic' PEVANS/Scalar-List-Utils-1.53.tar.gz C:\strawberry\c\bin\dmake.exe test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports PEVANS/Scalar-List-Utils-1.53.tar.gz Running make install make test had returned bad status, won't install without force Stopping: 'install' failed for 'List::Util'. Failed during this command: PEVANS/Scalar-List-Utils-1.53.tar.gz : make_test NO
Download (untitled) / with headers
text/html 11.2k
Subject: Re: [rt.cpan.org #130935] AutoReply: Install problem
Date: Sun, 10 Nov 2019 19:10:12 -0600
To: bug-Scalar-List-Utils [...] rt.cpan.org
From: Don Petersen <dpetersen112 [...] gmail.com>
Download (untitled) / with headers
text/plain 5.4k
Hi, I posted this installer bug 3 days ago and have seen no activity. Am I likely to see any? I'd like to keep moving forward with my code. If this is not likely to get attention soon, I'll look for another solution. Thx. On Thu, Nov 7, 2019 at 10:55 AM Bugs in Scalar-List-Utils via RT < bug-Scalar-List-Utils@rt.cpan.org> wrote: Show quoted text
> > Greetings, > > This message has been automatically generated in response to the > creation of a trouble ticket regarding: > "Install problem", > a summary of which appears below. > > There is no need to reply to this message right now. Your ticket has been > assigned an ID of [rt.cpan.org #130935]. Your ticket is accessible > on the web at: > > https://rt.cpan.org/Ticket/Display.html?id=130935 > > Please include the string: > > [rt.cpan.org #130935] > > in the subject line of all future correspondence about this issue. To do > so, > you may reply to this message. > > Thank you, > bug-Scalar-List-Utils@rt.cpan.org > > ------------------------------------------------------------------------- > When I tried installing Dancer2, I got the errors listed below. > > platform: HP Win10 Home, 64 bit, V 1809, build 17763.805 > > This is perl 5, version 16, subversion 3 (v5.16.3) built for > MSWin32-x64-multi-thread > > reports PEVANS/Scalar-List-Utils-1.53.tar.gz > listed many +PASS, several -FAIL, and a few UNKNOWN > > The abridged output from
> cpan> install Dancer2
> . > . > . > > CPAN.pm: Building C/CR/CROMEDOME/Dancer2-0.208001.tar.gz > Checking if your kit is complete... > Looks good > Warning: prerequisite App::Cmd::Setup 0 not found. > Warning: prerequisite Config::Any 0 not found. > Warning: prerequisite Exporter::Tiny 0 not found. > Warning: prerequisite File::Share 0 not found. > Warning: prerequisite Hash::Merge::Simple 0 not found. > Warning: prerequisite Hash::MultiValue 0 not found. > Warning: prerequisite Import::Into 0 not found. > Warning: prerequisite JSON::MaybeXS 0 not found. > Warning: prerequisite List::Util 1.29 not found. We have 1.27. > Warning: prerequisite Moo 2.000000 not found. We have 1.000008. > Warning: prerequisite Plack 1.0040 not found. > Warning: prerequisite Plack::Middleware::FixMissingBodyInRedirect 0 not > found. > Warning: prerequisite Plack::Middleware::RemoveRedundantBody 0 not found. > Warning: prerequisite Return::MultiLevel 0 not found. > Warning: prerequisite Role::Tiny 2.000000 not found. We have 1.002005. > Warning: prerequisite Safe::Isa 0 not found. > Warning: prerequisite Test::CPAN::Meta 0 not found. > Warning: prerequisite Test::EOL 0 not found. > Warning: prerequisite Type::Tiny 1.000006 not found. > Warning: prerequisite Types::Standard 0 not found. > Generating a dmake-style Makefile > Writing Makefile for Dancer2 > Writing MYMETA.yml and MYMETA.json > ---- Unsatisfied dependencies detected during ---- > ---- CROMEDOME/Dancer2-0.208001.tar.gz ---- > . > . > . > Running make test > C:\"strawberry\perl\bin\perl.exe" -MExtUtils::Command::MM -e cp_nonempty -- > Util.bs blib\arch\auto\List\Util\Util.bs 644 > C:\"strawberry\perl\bin\perl.exe" "-MExtUtils::Command::MM" > "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, > 'blib\lib', 'blib\arch')" t/*.t > t/00version.t ......... ok > t/any-all.t ........... ok > t/blessed.t ........... ok > t/dualvar.t ........... ok > t/exotic_names.t ...... ok > t/first.t ............. ok > t/getmagic-once.t ..... ok > t/head-tail.t ......... ok > t/isvstring.t ......... ok > t/lln.t ............... ok > t/max.t ............... ok > t/maxstr.t ............ ok > t/min.t ............... ok > t/minstr.t ............ ok > t/openhan.t ........... ok > t/pair.t .............. ok > t/product.t ........... ok > t/prototype.t ......... ok > t/readonly.t .......... ok > t/reduce.t ............ ok > t/refaddr.t ........... ok > t/reftype.t ........... ok > t/rt-96343.t .......... ok > t/scalarutil-proto.t .. ok > t/shuffle.t ........... ok > t/stack-corruption.t .. ok > t/subname.t ........... ok > t/sum.t ............... ok > t/sum0.t .............. ok > t/tainted.t ........... ok > t/uniq.t .............. 1/33 Argument "1.#INF" isn't numeric in subroutine > entry at t/uniq.t line 115. > Argument "-1.#IND" isn't numeric in subroutine entry at t/uniq.t line 115. > # Failed test 'uniqnum preserves uniqness of full integer range > (stringified)' > # at t/uniq.t line 115. > # Structures begin differing at: > # $got->[4] = '9223372036854775807' > # $expected->[4] = '-1.#IND' > # Looks like you failed 1 test of 33. > t/uniq.t .............. Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/33 subtests > t/weak.t .............. ok > Test Summary Report > ------------------- > t/uniq.t (Wstat: 256 Tests: 33 Failed: 1) > Failed test: 18 > Non-zero exit status: 1 > Files=32, Tests=2091, 11 wallclock secs ( 0.55 usr + 0.19 sys = 0.73 CPU) > Result: FAIL > Failed 1/32 test programs. 1/2091 subtests failed. > dmake.exe: Error code 255, while making 'test_dynamic' > PEVANS/Scalar-List-Utils-1.53.tar.gz > C:\strawberry\c\bin\dmake.exe test -- NOT OK > //hint// to see the cpan-testers results for installing this module, try: > reports PEVANS/Scalar-List-Utils-1.53.tar.gz > Running make install > make test had returned bad status, won't install without force > Stopping: 'install' failed for 'List::Util'. > Failed during this command: > PEVANS/Scalar-List-Utils-1.53.tar.gz : make_test NO >
Download (untitled) / with headers
text/plain 563b
Hi, Looks like uniq is upset about the rendering of Infinite values. As a short-term fix you can likely just ignore around it and force-install it. I see you're running a very old perl (5.16) on MSWin32. According to the test matrix http://matrix.cpantesters.org/?dist=Scalar-List-Utils+1.53 it is known to fail in that way for those old versions. There are fails upt o 5.20, but from 5.22 onwards it appears OK. 5.16 was end-of-life many years ago now. As a longer-term fix I'd suggest updating to a less ancient version of Perl. Thanks, -- Paul Evans
Subject: Re: [rt.cpan.org #130935] Install problem
Date: Mon, 11 Nov 2019 06:32:00 -0600
To: bug-Scalar-List-Utils [...] rt.cpan.org
From: Don Petersen <dpetersen112 [...] gmail.com>
Download (untitled) / with headers
text/plain 881b
Thx for the response. Fyi, I downloaded Perl (strawberry) about a month ago. This is concerning that their release is so old. On Mon, Nov 11, 2019, 4:33 AM Paul Evans via RT < bug-Scalar-List-Utils@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=130935 > > > Hi, > > Looks like uniq is upset about the rendering of Infinite values. As a > short-term fix you can likely just ignore around it and force-install it. > > I see you're running a very old perl (5.16) on MSWin32. According to the > test matrix > > http://matrix.cpantesters.org/?dist=Scalar-List-Utils+1.53 > > it is known to fail in that way for those old versions. There are fails > upt o 5.20, but from 5.22 onwards it appears OK. > > 5.16 was end-of-life many years ago now. As a longer-term fix I'd suggest > updating to a less ancient version of Perl. > > Thanks, > > -- > > Paul Evans >
Download (untitled) / with headers
text/plain 362b
On Mon Nov 11 12:32:21 2019, dpetersen112@gmail.com wrote: Show quoted text
> Thx for the response. Fyi, I downloaded Perl (strawberry) about a month > ago. This is concerning that their release is so old.
Their release isn't old, you must have downloaded an older one from their releases page: http://strawberryperl.com/releases.html Their v5.16.3 build dates from 13/03/2013


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.