Skip Menu |
 

This queue is for tickets about the Perinci-Exporter CPAN distribution.

Report information
The Basics
Id: 130351
Status: open
Priority: 0/
Queue: Perinci-Exporter

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 0.081
  • 0.082
Fixed in: (no value)



Subject: Undeclared dependencies
Download (untitled) / with headers
text/plain 1.1k
At least Perinci::Sub::Wrapper seems to be undeclared: ... Can't locate Perinci/Sub/Wrapper.pm in @INC (you may need to install the Perinci::Sub::Wrapper module) (@INC contains: t/lib ... .) at /usr/home/cpansand/.cpan/build/2019082020/Perinci-Exporter-0.081-3/blib/lib/Perinci/Exporter.pm line 237. BEGIN failed--compilation aborted at t/00-sanity.t line 19. t/00-sanity.t ............ Dubious, test returned 2 (wstat 512, 0x200) No subtests run ... Also on some of my smokers the test suite fails because of missing Perinci::Sub::Property::curry: ... # Failed test 'import doesn't die' # at t/01-basics.t line 321. # Can't locate Perinci/Sub/Property/curry.pm in @INC (you may need to install the Perinci::Sub::Property::curry module) (@INC contains: /usr/home/cpansand/.cpan/build/2019082020/Perinci-Exporter-0.081-0/blib/lib /usr/home/cpansand/.cpan/build/2019082020/Perinci-Exporter-0.081-0/blib/arch /usr/perl5.26.3p/lib/site_perl/5.26.3/amd64-freebsd /usr/perl5.26.3p/lib/site_perl/5.26.3 /usr/perl5.26.3p/lib/5.26.3/amd64-freebsd /usr/perl5.26.3p/lib/5.26.3 .) at /usr/perl5.26.3p/lib/site_perl/5.26.3/Perinci/Sub/Wrapper.pm line 1180. # Looks like you failed 1 test of 1. ...
Download (untitled) / with headers
text/plain 127b
Released 0.083 that fixes this. efa3118 Skip tests that need Perinci::Sub::Wrapper as it's now an optional prereq [RT#130351]
Download (untitled) / with headers
text/plain 590b
On 2019-09-10 01:44:06, PERLANCAR wrote: Show quoted text
> Released 0.083 that fixes this. > > efa3118 Skip tests that need Perinci::Sub::Wrapper as it's now an > optional prereq [RT#130351]
0.084 again fails: ... Can't locate Perinci/Sub/Wrapper.pm in @INC (you may need to install the Perinci::Sub::Wrapper module) (@INC contains: ... .) at /home/cpansand/.cpan/build/2019091102/Perinci-Exporter-0.084-0YYXtc/blib/lib/Perinci/Exporter.pm line 237. BEGIN failed--compilation aborted at t/00-sanity.t line 19. t/00-sanity.t ............ Dubious, test returned 2 (wstat 512, 0x200) No subtests run ...


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.