Skip Menu |
 

This queue is for tickets about the App-DocKnot CPAN distribution.

Report information
The Basics
Id: 129958
Status: resolved
Priority: 0/
Queue: App-DocKnot

People
Owner: RRA [...] cpan.org
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 3.00
Fixed in: 3.01



Subject: Wrong perl used in tests
t/dist/basic.t fails on my smokers, because the wrong perl is used here --- the first one in user's PATH, which is the system perl, not the perl currently used for the build: ... Can't locate Module/Build.pm in @INC (you may need to install the Module::Build module) (@INC contains: ... /usr/local/lib/perl5/5.28/mach /usr/local/lib/perl5/5.28 .) at Build.PL line 15. BEGIN failed--compilation aborted at Build.PL line 15. # Failed test 'dist exists' # at t/dist/basic.t line 76. # Failed test 'no errors' # at t/dist/basic.t line 78. # got: '"perl" unexpectedly returned exit value 2 at /usr/home/cpansand/.cpan/build/2019070114/App-DocKnot-3.00-1/blib/lib/App/DocKnot/Dist.pm line 186. # ' # expected: '' # Looks like you failed 2 tests of 3. t/dist/basic.t .............. Dubious, test returned 2 (wstat 512, 0x200) Failed 2/3 subtests ... Usually this can be fixed by calling the script explicitly with $^X, or using the blib/script version of the script (because there the shebang should be already fixed).
Subject: Re: [rt.cpan.org #129958] Wrong perl used in tests
Date: Mon, 01 Jul 2019 14:07:40 -0700
To: "Slaven_Rezic via RT" <bug-App-DocKnot [...] rt.cpan.org>
From: Russ Allbery <rra [...] cpan.org>
Download (untitled) / with headers
text/plain 745b
"Slaven_Rezic via RT" <bug-App-DocKnot@rt.cpan.org> writes: Show quoted text
> t/dist/basic.t fails on my smokers, because the wrong perl is used here > --- the first one in user's PATH, which is the system perl, not the perl > currently used for the build:
Oh, thank you! I saw various other things failed pretty badly with the new release but I hadn't picked up on that one. Really appreciate the diagnosis! I'll try to get this fixed fairly soon with a new release. -- #!/usr/bin/perl -- Russ Allbery, Just Another Perl Hacker $^=q;@!>~|{>krw>yn{u<$$<[~||<Juukn{=,<S~|}<Jwx}qn{<Yn{u<Qjltn{ > 0gFzD gD, 00Fz, 0,,( 0hF 0g)F/=, 0> "L$/GEIFewe{,$/ 0C$~> "@=,m,|,(e 0.), 01,pnn,y{ rw} >;,$0=q,$,,($_=$^)=~y,$/ C-~><@=\n\r,-~$:-u/ #y,d,s,(\$.),$1,gee,print
Fixed in 3.01.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.