Skip Menu |
 

This queue is for tickets about the ExtUtils-MakeMaker CPAN distribution.

Report information
The Basics
Id: 129763
Status: new
Priority: 0/
Queue: ExtUtils-MakeMaker

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 7.36
Fixed in: (no value)



Subject: t/pod2man.t may fail with perl 5.12.x
Download (untitled) / with headers
text/plain 516b
Seen on two perl5.12.5 installations: ... # Failed test at t/pod2man.t line 22. # 'UTF-16 surrogate 0xd800 at /opt/perl-5.12.5/lib/site_perl/5.12.5/Pod/Simple/BlackBox.pm line 67. # Option perm_rw requires an argument # ' # doesn't match '(?-xism:^Option perm_rw requires an argument)' # Looks like you failed 1 test of 3. t/pod2man.t ............... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/3 subtests ... This seems to happen only if newer Pod::Simple (3.38?) is installed.
Download (untitled) / with headers
text/plain 852b
On 2019-06-07 02:00:16, SREZIC wrote: Show quoted text
> Seen on two perl5.12.5 installations: > > ... > # Failed test at t/pod2man.t line 22. > # 'UTF-16 surrogate 0xd800 at /opt/perl- > 5.12.5/lib/site_perl/5.12.5/Pod/Simple/BlackBox.pm line 67. > # Option perm_rw requires an argument > # ' > # doesn't match '(?-xism:^Option perm_rw requires an argument)' > # Looks like you failed 1 test of 3. > t/pod2man.t ............... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/3 subtests > ... > > This seems to happen only if newer Pod::Simple (3.38?) is installed.
Looked at CPAN Testers and found more similar fail reports: * http://www.cpantesters.org/cpan/report/104903635 * http://www.cpantesters.org/cpan/report/104903601 * http://www.cpantesters.org/cpan/report/104900596 So perl 5.10.x and perl 5.8.x are also affected.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.