Skip Menu |
 

This queue is for tickets about the Sah-Schemas-Perl CPAN distribution.

Report information
The Basics
Id: 129741
Status: new
Priority: 0/
Queue: Sah-Schemas-Perl

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 0.019
  • 0.020
  • 0.023
Fixed in: (no value)



Subject: Foo::Bar vs. Foo-Bar (0.019)
Download (untitled) / with headers
text/plain 2.5k
The test suite fails on some of my smokers: ... Coercion rule module 'Data::Sah::Coerce::perl::str::str_convert_perl_pm_to_path' is still at metadata version 4, will not be used at /usr/perl5.22.2t/lib/site_perl/5.22.2/Data/Sah/CoerceCommon.pm line 219. Coercion rule module 'Data::Sah::Coerce::perl::str::str_normalize_perl_modname_or_prefix' is still at metadata version 4, will not be used at /usr/perl5.22.2t/lib/site_perl/5.22.2/Data/Sah/CoerceCommon.pm line 219. Coercion rule module 'Data::Sah::Coerce::perl::str::str_convert_perl_pod_or_pm_to_path' is still at metadata version 4, will not be used at /usr/perl5.22.2t/lib/site_perl/5.22.2/Data/Sah/CoerceCommon.pm line 219. Coercion rule module 'Data::Sah::Coerce::perl::str::str_convert_perl_pm_or_pod_to_path' is still at metadata version 4, will not be used at /usr/perl5.22.2t/lib/site_perl/5.22.2/Data/Sah/CoerceCommon.pm line 219. Coercion rule module 'Data::Sah::Coerce::perl::str::str_normalize_perl_modprefix' is still at metadata version 4, will not be used at /usr/perl5.22.2t/lib/site_perl/5.22.2/Data/Sah/CoerceCommon.pm line 219. Coercion rule module 'Data::Sah::Coerce::perl::str::str_normalize_perl_modname' is still at metadata version 4, will not be used at /usr/perl5.22.2t/lib/site_perl/5.22.2/Data/Sah/CoerceCommon.pm line 219. Coercion rule module 'Data::Sah::Coerce::perl::str::str_normalize_perl_distname' is still at metadata version 4, will not be used at /usr/perl5.22.2t/lib/site_perl/5.22.2/Data/Sah/CoerceCommon.pm line 219. Coercion rule module 'Data::Sah::Coerce::perl::str::str_convert_perl_pod_to_path' is still at metadata version 4, will not be used at /usr/perl5.22.2t/lib/site_perl/5.22.2/Data/Sah/CoerceCommon.pm line 219. # Failed test at t/perl-distname.t line 20. # got: 'Foo::Bar' # expected: 'Foo-Bar' # Failed test at t/perl-distname.t line 21. # got: 'Foo:Bar' # expected: 'Foo-Bar' # Failed test at t/perl-distname.t line 22. # got: 'Foo/Bar' # expected: 'Foo-Bar' # Failed test at t/perl-distname.t line 23. # got: 'Foo.Bar' # expected: 'Foo-Bar' # Failed test at t/perl-distname.t line 24. # got: 'Foo/Bar.pm' # expected: 'Foo-Bar' # Looks like you failed 5 tests of 9. # Failed test 'coercion' # at t/perl-distname.t line 25. # Looks like you failed 1 test of 1. t/perl-distname.t ............ Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests ... (etc) ... The only pattern I see is that this happens more often on older systems (CentOS 6, debian/wheezy).


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.