This queue is for tickets about the Devel-TRay CPAN distribution.

Report information
The Basics
Id:
129078
Status:
new
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
SREZIC [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
0.03
Fixed in:
(no value)



Subject: Undeclared dependency MetaCPAN::Client
The test suite fails on most of my smoker systems: ... # Failed test 'use Devel::TRay;' # at t/01_basic.t line 6. # Tried to use 'Devel::TRay'. # Error: Can't locate MetaCPAN/Client.pm in @INC (you may need to install the MetaCPAN::Client module) (@INC contains: /home/cpansand/.cpan/build/2019040820/Devel-TRay-0.03-LhCNE6/blib/lib /home/cpansand/.cpan/build/2019040820/Devel-TRay-0.03-LhCNE6/blib/arch /opt/perl-5.18.4/lib/site_perl/5.18.4/x86_64-linux /opt/perl-5.18.4/lib/site_perl/5.18.4 /opt/perl-5.18.4/lib/5.18.4/x86_64-linux /opt/perl-5.18.4/lib/5.18.4 .) at /home/cpansand/.cpan/build/2019040820/Devel-TRay-0.03-LhCNE6/blib/lib/Devel/TRay.pm line 86. # BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2019040820/Devel-TRay-0.03-LhCNE6/blib/lib/Devel/TRay.pm line 86. # Compilation failed in require at t/01_basic.t line 6. # BEGIN failed--compilation aborted at t/01_basic.t line 6. ... Additionally, it seems that something is using the first perl in PATH (on my smokers this is the system perl) and not the perl used to build & test the distribution.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.