Skip Menu |
 

This queue is for tickets about the Colouring-In CPAN distribution.

Report information
The Basics
Id: 129047
Status: open
Priority: 0/
Queue: Colouring-In

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 0.12
  • 0.15
Fixed in: (no value)



Subject: Test suite fails (with uselongdouble perls?)
Download (untitled) / with headers
text/plain 1.6k
On some of my smoker systems the test suite fails: ... # Failed test 'expected colour!' # at t/03-new-colours.t line 137. # Structures begin differing at: # $got->[2] = '8.29414661951410892e-17' # $expected->[2] = '0' # Failed test 'expected colour!' # at t/03-new-colours.t line 137. # Structures begin differing at: # $got->[2] = '8.29414661951410892e-17' # $expected->[2] = '0' # Looks like you failed 2 tests of 6. # Failed test 'basics - red' # at t/03-new-colours.t line 99. # Looks like you failed 1 test of 4. t/03-new-colours.t .. Dubious, test returned 1 (wstat 256, 0x100) Failed 1/4 subtests t/04-lighten.t ...... ok # Failed test 'expected colour!' # at t/05-darken.t line 62. # Structures begin differing at: # $got->[0] = '101' # $expected->[0] = '102' # Looks like you failed 1 test of 10. # Failed test 'basics - black' # at t/05-darken.t line 56. # Looks like you failed 1 test of 1. t/05-darken.t ....... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests t/06-fade.t ......... ok t/07-white-black.t .. ok # Failed test 'rgba(255,255,255,0.01)' # at t/08-fadeout.t line 67. # got: 'rgba(255,255,255,0.00999999999999999999)' # expected: 'rgba(255,255,255,0.01)' # Looks like you failed 1 test of 11. # Failed test 'basics - white' # at t/08-fadeout.t line 61. # Looks like you failed 1 test of 1. t/08-fadeout.t ...... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests ... (etc) ... This seems to happen if perl is compiled with increased floating point accuracy (i.e. with -Duselongdouble).
Download (untitled) / with headers
text/plain 3.1k
On 2019-04-07 13:43:22, SREZIC wrote: Show quoted text
> On some of my smoker systems the test suite fails: > > ... > # Failed test 'expected colour!' > # at t/03-new-colours.t line 137. > # Structures begin differing at: > # $got->[2] = '8.29414661951410892e-17' > # $expected->[2] = '0' > > # Failed test 'expected colour!' > # at t/03-new-colours.t line 137. > # Structures begin differing at: > # $got->[2] = '8.29414661951410892e-17' > # $expected->[2] = '0' > # Looks like you failed 2 tests of 6. > > # Failed test 'basics - red' > # at t/03-new-colours.t line 99. > # Looks like you failed 1 test of 4. > t/03-new-colours.t .. > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/4 subtests > t/04-lighten.t ...... ok > > # Failed test 'expected colour!' > # at t/05-darken.t line 62. > # Structures begin differing at: > # $got->[0] = '101' > # $expected->[0] = '102' > # Looks like you failed 1 test of 10. > > # Failed test 'basics - black' > # at t/05-darken.t line 56. > # Looks like you failed 1 test of 1. > t/05-darken.t ....... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests > t/06-fade.t ......... ok > t/07-white-black.t .. ok > > # Failed test 'rgba(255,255,255,0.01)' > # at t/08-fadeout.t line 67. > # got: 'rgba(255,255,255,0.00999999999999999999)' > # expected: 'rgba(255,255,255,0.01)' > # Looks like you failed 1 test of 11. > > # Failed test 'basics - white' > # at t/08-fadeout.t line 61. > # Looks like you failed 1 test of 1. > t/08-fadeout.t ...... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests > ... (etc) ... > > > This seems to happen if perl is compiled with increased floating point > accuracy (i.e. with -Duselongdouble).
Still failing with 0.15, but test log looks different now: ... # Failed test 'expected colour!' # at t/04-lighten.t line 67. # Structures begin differing at: # $got->[0] = '50' # $expected->[0] = '51' # Failed test 'expected colour!' # at t/04-lighten.t line 67. # Structures begin differing at: # $got->[0] = '101' # $expected->[0] = '102' # Failed test 'expected colour!' # at t/04-lighten.t line 67. # Structures begin differing at: # $got->[0] = '152' # $expected->[0] = '153' # Failed test 'expected colour!' # at t/04-lighten.t line 67. # Structures begin differing at: # $got->[0] = '203' # $expected->[0] = '204' # Looks like you failed 4 tests of 11. # Failed test 'basics - black' # at t/04-lighten.t line 61. # Looks like you failed 1 test of 1. t/04-lighten.t ...... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests # Failed test 'expected colour!' # at t/05-darken.t line 62. # Structures begin differing at: # $got->[0] = '51' # $expected->[0] = '50' # Looks like you failed 1 test of 10. # Failed test 'basics - black' # at t/05-darken.t line 56. # Looks like you failed 1 test of 1. t/05-darken.t ....... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests ...
Subject: Re: [rt.cpan.org #129047] Test suite fails (with uselongdouble perls?)
Date: Sun, 23 Feb 2020 01:40:17 +0700
To: bug-Colouring-In [...] rt.cpan.org
From: "LNATION ." <thisusedtobeanemail [...] gmail.com>
Download (untitled) / with headers
text/plain 3.7k
I guess thats because of the offset value i have set? I hope you understand what I'm trying to resolve, despite it might not being the best solution. If you have any ideas on how to make this better then please let me know. On Sat, 22 Feb 2020, 21:54 Slaven_Rezic via RT, < bug-Colouring-In@rt.cpan.org> wrote: Show quoted text
> Queue: Colouring-In > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=129047 > > > On 2019-04-07 13:43:22, SREZIC wrote:
> > On some of my smoker systems the test suite fails: > > > > ... > > # Failed test 'expected colour!' > > # at t/03-new-colours.t line 137. > > # Structures begin differing at: > > # $got->[2] = '8.29414661951410892e-17' > > # $expected->[2] = '0' > > > > # Failed test 'expected colour!' > > # at t/03-new-colours.t line 137. > > # Structures begin differing at: > > # $got->[2] = '8.29414661951410892e-17' > > # $expected->[2] = '0' > > # Looks like you failed 2 tests of 6. > > > > # Failed test 'basics - red' > > # at t/03-new-colours.t line 99. > > # Looks like you failed 1 test of 4. > > t/03-new-colours.t .. > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/4 subtests > > t/04-lighten.t ...... ok > > > > # Failed test 'expected colour!' > > # at t/05-darken.t line 62. > > # Structures begin differing at: > > # $got->[0] = '101' > > # $expected->[0] = '102' > > # Looks like you failed 1 test of 10. > > > > # Failed test 'basics - black' > > # at t/05-darken.t line 56. > > # Looks like you failed 1 test of 1. > > t/05-darken.t ....... > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/1 subtests > > t/06-fade.t ......... ok > > t/07-white-black.t .. ok > > > > # Failed test 'rgba(255,255,255,0.01)' > > # at t/08-fadeout.t line 67. > > # got: 'rgba(255,255,255,0.00999999999999999999)' > > # expected: 'rgba(255,255,255,0.01)' > > # Looks like you failed 1 test of 11. > > > > # Failed test 'basics - white' > > # at t/08-fadeout.t line 61. > > # Looks like you failed 1 test of 1. > > t/08-fadeout.t ...... > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/1 subtests > > ... (etc) ... > > > > > > This seems to happen if perl is compiled with increased floating point > > accuracy (i.e. with -Duselongdouble).
> > Still failing with 0.15, but test log looks different now: > > ... > # Failed test 'expected colour!' > # at t/04-lighten.t line 67. > # Structures begin differing at: > # $got->[0] = '50' > # $expected->[0] = '51' > > # Failed test 'expected colour!' > # at t/04-lighten.t line 67. > # Structures begin differing at: > # $got->[0] = '101' > # $expected->[0] = '102' > > # Failed test 'expected colour!' > # at t/04-lighten.t line 67. > # Structures begin differing at: > # $got->[0] = '152' > # $expected->[0] = '153' > > # Failed test 'expected colour!' > # at t/04-lighten.t line 67. > # Structures begin differing at: > # $got->[0] = '203' > # $expected->[0] = '204' > # Looks like you failed 4 tests of 11. > > # Failed test 'basics - black' > # at t/04-lighten.t line 61. > # Looks like you failed 1 test of 1. > t/04-lighten.t ...... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests > > # Failed test 'expected colour!' > # at t/05-darken.t line 62. > # Structures begin differing at: > # $got->[0] = '51' > # $expected->[0] = '50' > # Looks like you failed 1 test of 10. > > # Failed test 'basics - black' > # at t/05-darken.t line 56. > # Looks like you failed 1 test of 1. > t/05-darken.t ....... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests > ... > >
Download (untitled) / with headers
text/plain 4.6k
The difference between a normal and a uselongdouble perl (showing also the Devel::Peek::Dump output) SV = PVNV(0x55c7c923e190) at 0x55c7c92659a8 REFCNT = 2 FLAGS = (IOK,NOK,POK,pIOK,pNOK,pPOK) IV = 51 NV = 51 PV = 0x55c7c86d48c0 "51"\0 CUR = 2 LEN = 32 x sprintf( "%d", $n ) ā†’ 51 --- SV = PVNV(0x560a5f4b9100) at 0x560a5f4df508 REFCNT = 2 FLAGS = (NOK,pIOK,pNOK) IV = 50 NV = 51 PV = 0 x sprintf( "%d", $n ) ā†’ 50 --- The latter looks fishy (IV=50 which is different from the NV value). I suspect some issue with smallnum.pm, but I am completely out for further debugging. Regards, Slaven On 2020-02-22 13:40:44, thisusedtobeanemail@gmail.com wrote: Show quoted text
> I guess thats because of the offset value i have set? I hope you understand > what I'm trying to resolve, despite it might not being the best solution. > If you have any ideas on how to make this better then please let me know. > > On Sat, 22 Feb 2020, 21:54 Slaven_Rezic via RT, < > bug-Colouring-In@rt.cpan.org> wrote: >
> > Queue: Colouring-In > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=129047 > > > > > On 2019-04-07 13:43:22, SREZIC wrote:
> > > On some of my smoker systems the test suite fails: > > > > > > ... > > > # Failed test 'expected colour!' > > > # at t/03-new-colours.t line 137. > > > # Structures begin differing at: > > > # $got->[2] = '8.29414661951410892e-17' > > > # $expected->[2] = '0' > > > > > > # Failed test 'expected colour!' > > > # at t/03-new-colours.t line 137. > > > # Structures begin differing at: > > > # $got->[2] = '8.29414661951410892e-17' > > > # $expected->[2] = '0' > > > # Looks like you failed 2 tests of 6. > > > > > > # Failed test 'basics - red' > > > # at t/03-new-colours.t line 99. > > > # Looks like you failed 1 test of 4. > > > t/03-new-colours.t .. > > > Dubious, test returned 1 (wstat 256, 0x100) > > > Failed 1/4 subtests > > > t/04-lighten.t ...... ok > > > > > > # Failed test 'expected colour!' > > > # at t/05-darken.t line 62. > > > # Structures begin differing at: > > > # $got->[0] = '101' > > > # $expected->[0] = '102' > > > # Looks like you failed 1 test of 10. > > > > > > # Failed test 'basics - black' > > > # at t/05-darken.t line 56. > > > # Looks like you failed 1 test of 1. > > > t/05-darken.t ....... > > > Dubious, test returned 1 (wstat 256, 0x100) > > > Failed 1/1 subtests > > > t/06-fade.t ......... ok > > > t/07-white-black.t .. ok > > > > > > # Failed test 'rgba(255,255,255,0.01)' > > > # at t/08-fadeout.t line 67. > > > # got: 'rgba(255,255,255,0.00999999999999999999)' > > > # expected: 'rgba(255,255,255,0.01)' > > > # Looks like you failed 1 test of 11. > > > > > > # Failed test 'basics - white' > > > # at t/08-fadeout.t line 61. > > > # Looks like you failed 1 test of 1. > > > t/08-fadeout.t ...... > > > Dubious, test returned 1 (wstat 256, 0x100) > > > Failed 1/1 subtests > > > ... (etc) ... > > > > > > > > > This seems to happen if perl is compiled with increased floating point > > > accuracy (i.e. with -Duselongdouble).
> > > > Still failing with 0.15, but test log looks different now: > > > > ... > > # Failed test 'expected colour!' > > # at t/04-lighten.t line 67. > > # Structures begin differing at: > > # $got->[0] = '50' > > # $expected->[0] = '51' > > > > # Failed test 'expected colour!' > > # at t/04-lighten.t line 67. > > # Structures begin differing at: > > # $got->[0] = '101' > > # $expected->[0] = '102' > > > > # Failed test 'expected colour!' > > # at t/04-lighten.t line 67. > > # Structures begin differing at: > > # $got->[0] = '152' > > # $expected->[0] = '153' > > > > # Failed test 'expected colour!' > > # at t/04-lighten.t line 67. > > # Structures begin differing at: > > # $got->[0] = '203' > > # $expected->[0] = '204' > > # Looks like you failed 4 tests of 11. > > > > # Failed test 'basics - black' > > # at t/04-lighten.t line 61. > > # Looks like you failed 1 test of 1. > > t/04-lighten.t ...... > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/1 subtests > > > > # Failed test 'expected colour!' > > # at t/05-darken.t line 62. > > # Structures begin differing at: > > # $got->[0] = '51' > > # $expected->[0] = '50' > > # Looks like you failed 1 test of 10. > > > > # Failed test 'basics - black' > > # at t/05-darken.t line 56. > > # Looks like you failed 1 test of 1. > > t/05-darken.t ....... > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/1 subtests > > ... > > > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.