Skip Menu |
 

This queue is for tickets about the Test-Kwalitee CPAN distribution.

Report information
The Basics
Id: 129000
Status: open
Priority: 0/
Queue: Test-Kwalitee

People
Owner: Nobody in particular
Requestors: rrwo [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Possible incompatabilities with Module::CPANTS::Analyse v0.98 or later
Date: Tue, 2 Apr 2019 17:28:22 +0100
To: bug-Test-Kwalitee [...] rt.cpan.org
From: Robert Rothenberg <rrwo [...] cpan.org>
Download (untitled) / with headers
text/plain 1.2k
When run with Module::CPANTS::Analyse v1.00 I get this wonderfully incorrect message: Show quoted text
> RELEASE_TESTING=1 prove -lr t/release-kwalitee.t > t/release-kwalitee.t .. 1/? > #   Failed test 'has_tests' > #   at t/release-kwalitee.t line 15. > # Error: This distribution doesn't contain either a file called > 'test.pl' or a directory called 't'. This indicates that it doesn't > contain even the most basic test-suite. This is really BAD! > # Details: > # Neither "test.pl" nor "t/" directory was not found. > # Remedy: Add tests! > # Looks like you failed 1 test of 18. > t/release-kwalitee.t .. Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/18 subtests > > Test Summary Report > ------------------- > t/release-kwalitee.t (Wstat: 256 Tests: 18 Failed: 1) >   Failed test:  10 >   Non-zero exit status: 1 > Files=1, Tests=18,  0 wallclock secs ( 0.01 usr  0.01 sys +  0.19 > cusr  0.02 csys =  0.23 CPU) > Result: FAIL
using the script generated by Dist::Zilla::Plugin::Test::Kwalitee 2.12 I tried installing Module::CPANTS::Analyse v0.96 and found that this now works. It also works with v0.97_11 but fails in v0.98 and later.  (Versions 0.98 and 1.00 claim to have backward incompatible changes.) For what its worth, I'm using Perl v5.28.1
Download (untitled) / with headers
text/plain 213b
On 2019-04-02 09:28:37, RRWO wrote: Show quoted text
> When run with Module::CPANTS::Analyse v1.00 I get this wonderfully > incorrect message:
I can't reproduce this. Can you point me to a repository that exhibits these symptoms?
Download (untitled) / with headers
text/plain 366b
On Wed May 08 23:27:15 2019, ETHER wrote: Show quoted text
> On 2019-04-02 09:28:37, RRWO wrote:
> > When run with Module::CPANTS::Analyse v1.00 I get this wonderfully > > incorrect message:
> > I can't reproduce this. Can you point me to a repository that exhibits > these symptoms?
For example, the git repo for HTML::DeferableCSS and using Dist::Zilla to run `dzil test --all`
Download (untitled) / with headers
text/plain 191b
On Fri May 29 18:57:41 2020, RRWO wrote: Show quoted text
> For example, the git repo for HTML::DeferableCSS and using Dist::Zilla > to run `dzil test --all`
At https://github.com/robrwo/HTML-DeferableCSS


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.