Skip Menu |
 

This queue is for tickets about the Test-PerlTidy CPAN distribution.

Report information
The Basics
Id: 128765
Status: resolved
Priority: 0/
Queue: Test-PerlTidy

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 20190309
Fixed in: (no value)



Subject: Perl::Tidy version mismatches
Download (untitled) / with headers
text/plain 783b
The test suite fails on some of my smoker systems (currently 20 out of 80 are affected, without a recognizable perl version or os pattern): ... # Failed test 'Test/PerlTidy.pm loaded ok' # at t/00-compile.t line 43. # got: '512' # expected: '0' Perl::Tidy version 20181120 required--this is only version 20140711 at /usr/perl5.20.1Dp/lib/5.20.1/Exporter/Heavy.pm line 125. BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2019030909/Test-PerlTidy-20190309-8gdl_Q/blib/lib/Test/PerlTidy.pm line 17. Compilation failed in require at -e line 1. # Looks like you failed 1 test of 1. t/00-compile.t ........ Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests ... (etc) ... On CPAN Testers I see also similar fail reports by other testers.
On 2019-03-09 03:40:44, SREZIC wrote: Show quoted text
> The test suite fails on some of my smoker systems (currently 20 out of > 80 are affected, without a recognizable perl version or os pattern):
It fails if an older Perl::Tidy version is already installed. The version specification here https://metacpan.org/source/SHLOMIF/Test-PerlTidy-20190309/lib/Test/PerlTidy.pm#L17 does not match with the version specification in the build+meta files. Show quoted text
> > ... > # Failed test 'Test/PerlTidy.pm loaded ok' > # at t/00-compile.t line 43. > # got: '512' > # expected: '0' > Perl::Tidy version 20181120 required--this is only version 20140711 at > /usr/perl5.20.1Dp/lib/5.20.1/Exporter/Heavy.pm line 125. > BEGIN failed--compilation aborted at > /home/cpansand/.cpan/build/2019030909/Test-PerlTidy-20190309- > 8gdl_Q/blib/lib/Test/PerlTidy.pm line 17. > Compilation failed in require at -e line 1. > # Looks like you failed 1 test of 1. > t/00-compile.t ........ > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/1 subtests > ... (etc) ... > > On CPAN Testers I see also similar fail reports by other testers.
Download (untitled) / with headers
text/plain 1.2k
On Sat Mar 09 04:30:41 2019, SREZIC wrote: Show quoted text
> On 2019-03-09 03:40:44, SREZIC wrote:
> > The test suite fails on some of my smoker systems (currently 20 out > > of > > 80 are affected, without a recognizable perl version or os pattern):
> > It fails if an older Perl::Tidy version is already installed. The > version specification here > https://metacpan.org/source/SHLOMIF/Test-PerlTidy- > 20190309/lib/Test/PerlTidy.pm#L17 does not match with the version > specification in the build+meta files. >
> > > > ... > > # Failed test 'Test/PerlTidy.pm loaded ok' > > # at t/00-compile.t line 43. > > # got: '512' > > # expected: '0' > > Perl::Tidy version 20181120 required--this is only version 20140711 > > at > > /usr/perl5.20.1Dp/lib/5.20.1/Exporter/Heavy.pm line 125. > > BEGIN failed--compilation aborted at > > /home/cpansand/.cpan/build/2019030909/Test-PerlTidy-20190309- > > 8gdl_Q/blib/lib/Test/PerlTidy.pm line 17. > > Compilation failed in require at -e line 1. > > # Looks like you failed 1 test of 1. > > t/00-compile.t ........ > > Dubious, test returned 1 (wstat 256, 0x100) > > Failed 1/1 subtests > > ... (etc) ... > > > > On CPAN Testers I see also similar fail reports by other testers.
should be fixed now. Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.