Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 128717
Status: open
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: violapiratejunky [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 2.064
Fixed in: (no value)



Subject: Installing in Perl docker build fails - Mozilla::CA not declared as a dependency
I'm using the official perl docker image based on Debian. My Dockerfile looks like this: FROM perl:5.28 RUN cpanm Carton \ && mkdir -p /app WORKDIR /app COPY cpanfile* /app/ RUN carton install --deployment COPY . /app EXPOSE 3000 CMD ["carton", "exec", "script/app", "daemon"] My cpanfile contains this line: requires 'IO::Socket::SSL'; Whenever I run docker build -t app . I get this error for the carton install --deployment step: ! Couldn't find module or a distribution Mozilla::CA ! Installing the dependencies failed: Module 'Mozilla::CA' is not installed ! Bailing out the installation for IO-Socket-SSL-2.064. It looks like Mozilla::CA isn't declared as a dependency? I had to add it to my cpanfile, and then IO::Socket::SSL installed.
Download (untitled) / with headers
text/plain 1.8k
Mozilla::CA is not a fixed dependency for IO::Socket::SSL. But it is declared as dependecy if no proper default CA can be found on the system. I'm not familiar where the problem exactly lies since I'm not familiar with the build process done on your system. Specifically I don't know if the problem is actually in the distribution I've provided or specific to how this distribution is packed and installed for your system - which is not in my control. I also don't get enough information from the output you've provided (which basically only says that something failed). In order to make debugging for me possible please do a build "the perl way", i.e. download the distribution, "perl Makefile.PL" and then "make test" (better "make TEST_VERBOSE=1 test" so that I get more debug information). If any of these steps fails please provide the output here. If none of this fails the problem seems to be outside of what I distribute, i.e. it is not my problem. Am Mo 04. Mär 2019, 23:18:18, srchulo schrieb: Show quoted text
> > I'm using the official perl docker image based on Debian. My > Dockerfile looks like this: > > FROM perl:5.28 > > RUN cpanm Carton \ > && mkdir -p /app > > WORKDIR /app > COPY cpanfile* /app/ > RUN carton install --deployment > COPY . /app > > EXPOSE 3000 > > CMD ["carton", "exec", "script/app", "daemon"] > > > > My cpanfile contains this line: > > requires 'IO::Socket::SSL'; > > Whenever I run > > docker build -t app . > > I get this error for the carton install --deployment step: > > > ! Couldn't find module or a distribution Mozilla::CA > ! Installing the dependencies failed: Module 'Mozilla::CA' is not > installed > ! Bailing out the installation for IO-Socket-SSL-2.064. > > It looks like Mozilla::CA isn't declared as a dependency? I had to add > it to my cpanfile, and then IO::Socket::SSL installed.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.