Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 128685
Status: resolved
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: PLICEASE [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Undeclared configure time prereq on Net::SSLeay
Download (untitled) / with headers
text/plain 712b
Net::SSLeay is declared as a runtime prereq, but cannot be used in Makefile.PL unless it is declared as a configure time prerequisite. What follows is the relevant part of the log from cpanm: ... IO-Socket-SSL-2.063/Changes IO-Socket-SSL-2.063/README.Win32 IO-Socket-SSL-2.063/META.yml IO-Socket-SSL-2.063/META.json Entering IO-Socket-SSL-2.063 Checking configure dependencies from META.json Checking if you have ExtUtils::MakeMaker 6.58 ... Yes (7.24) Running Makefile.PL Configuring IO-Socket-SSL-2.063 ... Undefined subroutine &Net::SSLeay::OPENSSL_VERSION_NUMBER called at Makefile.PL line 67. N/A ! Configure failed for IO-Socket-SSL-2.063. See /home/cip/.cpanm/work/1551486951.825/build.log for details.
fix released with 2.064


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.