Skip Menu |
 

This queue is for tickets about the Encode CPAN distribution.

Report information
The Basics
Id: 128601
Status: new
Priority: 0/
Queue: Encode

People
Owner: Nobody in particular
Requestors: jkeenan [...] pobox.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



CC: tokuhirom [...] gmail.com, tokuhirom [...] cpan.org
Subject: Encode 2.99 breaks Data-Recursive-Encode test suite
Date: Sat, 23 Feb 2019 09:30:26 -0500
To: bug-Encode [...] rt.cpan.org
From: James E Keenan <jkeenan [...] pobox.com>
Download (untitled) / with headers
text/plain 3.3k
As part of testing the "CPAN River 3000" against this week's release of perl-5.29.8, I tested CPAN distribution Data::Recursive::Encode. I got the following test failure while attempting to install with cpanm on FreeBSD-11.1: ##### { author => "TOKUHIROM", dist => "Data-Recursive-Encode", distname => "Data-Recursive-Encode-0.06", distversion => 0.06, grade => "FAIL", prereqs => undef, test_output => [ "Building and testing Data-Recursive-Encode-0.06", "Building Data-Recursive-Encode", "t/00_compile.t ..... ok", " # No tests run!", "", "# Failed test 'No tests run for subtest \"decode_utf8\"'", "# at t/01_simple.t line 38.", "Use of uninitialized value in subroutine entry at /usr/home/jkeenan/var/tad/testing/perl-5.29.8/.cpanm/work/1550768645.33532/Data-Recursive-Encode-0.06/blib/lib/Data/Recursive/Encode.pm line 72.", "# Tests were run but no plan was declared and done_testing() was not seen.", "# Looks like your test exited with 255 just after 1.", "t/01_simple.t ...... ", "Dubious, test returned 255 (wstat 65280, 0xff00)", "Failed 1/1 subtests ", " # No tests run!", "", "# Failed test 'No tests run for subtest \"decode_utf8\"'", "# at t/02_more.t line 25.", "Use of uninitialized value in subroutine entry at /usr/home/jkeenan/var/tad/testing/perl-5.29.8/.cpanm/work/1550768645.33532/Data-Recursive-Encode-0.06/blib/lib/Data/Recursive/Encode.pm line 72.", "# Tests were run but no plan was declared and done_testing() was not seen.", "# Looks like your test exited with 255 just after 1.", "t/02_more.t ........ ", "Dubious, test returned 255 (wstat 65280, 0xff00)", "Failed 1/1 subtests ", "t/03_recursive.t ... ok", "t/04_number.t ...... ok", "t/05_is_integer.t .. ok", "", "Test Summary Report", "-------------------", "t/01_simple.t (Wstat: 65280 Tests: 1 Failed: 1)", " Failed test: 1", " Non-zero exit status: 255", " Parse errors: No plan found in TAP output", "t/02_more.t (Wstat: 65280 Tests: 1 Failed: 1)", " Failed test: 1", " Non-zero exit status: 255", " Parse errors: No plan found in TAP output", "Files=6, Tests=21, 0 wallclock secs ( 0.02 usr 0.02 sys + 0.44 cusr 0.20 csys = 0.68 CPU)", "Result: FAIL", ], via => "App::cpanminus::reporter 0.17 (1.7044)", } ##### The failure was reproducible on Linux as well. Since Data::Recursive::Encode has a dependency on Encode, and since Encode is shipped with the Perl 5 core distribution, I hypothesized that the failure was due to an upgraded version of Encode shipped with perl-5.29.8. Bisection confirmed this: ##### 20797ee136d20e2b1a349821622af71c5da520cf is the first bad commit commit 20797ee136d20e2b1a349821622af71c5da520cf Author: Dan Kogai <dankogai@dan.co.jp> Date: Mon Jan 21 09:25:18 2019 -0500 Encode: synch with CPAN version 2.99 :100644 100644 5d1d5cca7b97695364e1be6db2638cf96baa2873 e282452028684831a042b5b1cd10a1758958cf03 M MANIFEST :040000 040000 6b9fee4497a3b26050fb4d3f1254ae6ce5a681c3 27c2013d9bc58f0c76e547216d44ec0791e36b19 M Porting :040000 040000 657883c42bcd84f5dfb464f5d8de4ead48f3458b 98cbcb0c30be01c6452cd9c5681de2219acc5884 M cpan bisect run success That took 2155 seconds. ##### Can you investigate? Thank you very much. Jim Keenan


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.