Skip Menu |
 

This queue is for tickets about the MediaWiki-API CPAN distribution.

Report information
The Basics
Id: 128532
Status: resolved
Priority: 0/
Queue: MediaWiki-API

People
Owner: buzz [...] exotica.org.uk
Requestors: steevithak [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Can't log in to recent version of mediawiki
Date: Sun, 17 Feb 2019 00:19:45 -0600
To: bug-MediaWiki-API [...] rt.cpan.org
From: Steve Rainwater <steevithak [...] gmail.com>
Download (untitled) / with headers
text/plain 282b
It appears the MediaWiki::API library is no longer able to login correctly to mediawiki due to some change in the login API. I am able to login to a very old version of mediawiki that I installed locally (version 1.19) but I'm not able to login on any currently supported versions.
Download (untitled) / with headers
text/plain 498b
I think this ticket can be closed. I was able to log in to the latest MediaWiki 1.33 with v0.41 of this module. Simple test script: #!/usr/bin/perl use MediaWiki::API; use Carp; use strict; use warnings; use version; our $VERSION = qv(0.1); my $mw = MediaWiki::API->new( { api_url => 'http://mediawiki-instance/api.php' } ); my $ret = $mw->login( { lgname => 'Username', lgpassword => 'validpassword' } ) || croak $mw->{error}->{code} . ': ' . $mw->{error}->{details}; carp Dumper( $ret );
Download (untitled) / with headers
text/plain 613b
On Sun Feb 17 01:19:53 2019, steevithak@gmail.com wrote: Show quoted text
> It appears the MediaWiki::API library is no longer able to login > correctly to mediawiki due to some change in the login API. I am able > to login to a very old version of mediawiki that I installed locally > (version 1.19) but I'm not able to login on any currently supported > versions.
It worked for me ok with the previous version (It didn't send a token by default, but when the response requested a token). However I have just updated it (v0.51) to use the new token API calls and it works here ok with MediaWiki 1.35.0 so I'll mark this closed.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.